ArduPlane reverse thrust setup


I replaced the ESC in my Plane running ArduPlane 3.8.0beta5 to a BlHeli ESCs with reverse enabled. When I am in manual mode, I now have to center the throttle stick to get zero throttle, throttle stick up for full forward throttle and throttle stick down for full reverse throttle. Is it possible to configure ArduPlane that it behaves like a non reverse thrust setup? It should be not possible to use reverse thrust in manual and FBWA mode, throttle stick down = 0% throttle, throttle stick up 100% (forward) throttle. Reverse thrust should only be used in USE_REV_THRUST enabled flight modes until a level of THR_MIN percent (i.e. -20%).

Thanks and regards

It should be not possible to use reverse thrust in manual

Manual is passthrough. Nothing the autopilot can do about that, sorry. I suggest not using MANUAL.

In general, the autopilot will only repsect the THR_MIN/MAX_TRIM values (and eveyrhtign else throttle related) in flight modes that control the throttle. Those modes are all listed in USE_REV_THRUST that you noted in your original post. Flight mode FBW A does not control the throttle, I suggest using FBW B which does control the throttle.

Hi Tom,

thanks for the reply. I already figured out how to do the setup described above, just waiting for better weather conditions to do a test flight. With my Pixracer manual is not only passthrough here, SERVO3_* and RC3_* change the output in manual flight mode too.

What I have done:
Set SERVO3_TRIM to 1500
Set THR_MIN to -25

With these settings it seems that it works as desired. Unfortunately in manual mode I could not set the throttle anymore, SERVO3 (PWM out to ESC) was fixed to 1500 irrespective of the throttle stick position. I could fix that by setting RC3_TRIM from 984 to 982. RC3_MIN is still at 984. If RC3_TRIM has the same value as RC3_MIN and SERVO3_TRIM is 1500 than it is not possible to set the throttle in manual flight mode (RC3 PWM out fixed to 1500), maybe that is a bug.

I will marked this as solved, hope to do the test flight this week.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

I’ve reproduced this, and it looks like this can only happen when using reverse thrust and RC3_MIN is exactly equal to RC3_TRIM. I’ll look at fixing that.

that is no longer true in 3.8.0. Manual does mixing in the same way other modes do mixing, so if you have the RC3_MIN/MAX over a different range from SERVO3_MIN/MAX.

i’ve posted a fix for the TRIM == MIN bug here:

1 Like