ArduPlane pitches up after autoland flare

Hi, I’m having some trouble tuning my ArduPlane to do a precise automatic landing. I already tuned the the Pitch/Roll, Navigation and TECS controllers as best I could. I’m using X-Plane 11 to run the simulations before putting this on my real rc plane. Here are my parameters for landing:

Here’s what’s happening with those settings: when the plane reaches LAND_FLARE_ALT, it pitches up to at most TECS_LAND_PMAX, and then slowly lowers the nose to try to maintain TECS_LAND_SINK until touchdown.

What I don’t like about this landing is the pitch up right after LAND_FLARE_ALT. I want the plane to find TECS_LAND_SINK much much quicker, without pitching up as much, regardless of the speed it is going at (I’ll be landing on grass, and the speed of the plane on landing is not a big concern as long as it’s precise and somewhat smooth). Which parameters should I change to limit the pitch up right after the flare while maintaining the desired sink rate?

Here’s a screenshot of a test I performed.

Let me know if you need more information!

Thanks a lot

If the plane doesn’t pitch up, how do you propose it will slow its sink rate? The altitude you have on your plot looks excellent.

You could look at the landing pre-flare settings. This will start to slow the plane earlier and may reduce the amount of pitching nose up. You could also plot your landing approach so it’s longer and shallower.

If you’re dead set against the nose pitching up, you’re going to need to look into some form of aero-braking, or reverse thrust.

Hey thank your for your response! For sure the plane needs to pitch up in order to slow its sink rate, but as can be seen, it pitches way to much, even as to exceed my TECS_LAND_SINK setting. I would like to tune it so it finds the correct sink rate quick in order to not miss the landing point.

Thank you for the aero-braking or reverse thrust tip! I’ll look into that!


Try those first. That will be a lot easier than braking or reverse thrust.