Servers by jDrones

Arduplane Auto Take-off

Hello. I’ve been testing the Auto-take off capability (for hand launching) in Arduplane. I’ve gone through the settings and created a mission (Take-off node and a return to launch so it loiters over me once it reaches desired altitude). However, after several attempts, I’ve noticed once I hand launch, it only flies leveled and does not gain altitude. Can someone please assist in the actual process to be able to hand launch and automatically fly to the specified altitude? I’m guessing I’m doing something wrong in my settings somewhere. Thank you in advance for your assistance.

You might like to try “takeoff mode” instead. It loiters at a
configurable height and distance in the direction you throw it.

Chances are you need a higher takeoff pitch - check your logs and see if
you were achieving a 4 degree pitch up.

The takeoff pitch is in parameter 1 of the takeoff mission item, in
degrees. If not specifed, 4 degrees is used. Assuming we’re talking
NAV_TAKEOFF

Thank you for your response. I greatly appreciate it. I will adjust my mission. I noticed I had the pitch angle in the papoint for Take-off set to 0. I’ve changed it to 15 and will test it this afternoon.

In regards to the take-off flight mode, I was unable to find it in the flight mode list. Is it something I need to set somewhere in the parameters instead?

Thank you again for taking the time and assisting me.

Here is your answer: https://discuss.ardupilot.org/t/plane-4-0-release/47188/153?u=tucuman79

1 Like

Thank you very much @tucuman79 for pointing me to the right direction. It appears the solution has worked successfully. Looks like I needed to follow some of the additional steps in order for the take-off mode to appear. I never would have found that in a million years. Do you know if this will be more easily available in the near future (without having to go thru the additional parameters steps)?

Thank you again! Cheers!

Hi, fortunately there was an update of Mission Planner two days ago. The Mission Planner’s updating function doesn’t work in my PC, I don’t know why, so I always download last version from here:

http://firmware.ardupilot.org/Tools/MissionPlanner/

Sure this last update should already includes takeoff mode.

I’m going to try this new mode today, hope it works!!! :pray:

Thanks for your response once again. I actually downloaded the latest mission planner yesterday once I read your response but still did not have the take-off mode easily accessible. I still had to go through the “F-7” way.

Your plane controller has a firmware version 4 or later? maybe Mission Planner “looks” at your firmware version to display takeoff mode because in previous firmware version this was not available.

Good pointed. I suspected that would be the case. I’ll upgrade today.

I tried takeoff mode for first time today but it is not working. Here is the thread about this issue:

Servers by jDrones