Arduplane 4.4.4 - During unlimited loiter turns aircraft enters controlled flight into terrain

Hi, good day!

i need some help regarding a flight i recently did. the mission was flown in automode, everything work great until the point in the mission it enters unlimited turns, the aircraft without warning enters a controlled flight into terrain. i tried changing flight modes to FBWA but there is no response from the elevator as seen in the logs, help/insight regarding the issue will be very appreciated.

Flight trajectory :


Hi @Zeke_De_Zilva,

I am very sure that a mechanical fault in the elevator or elevator servo is the cause.
Arduplane reacted completely correctly and tried to counteract the increasing steepness of the descent.
Pitch (red) and target pitch (green) diverge quite suddenly shortly before the crash, although the elevator output (blue) is almost fully “pulling”.

No CFIT, elevator failure in my opinion.


Hi Rolf,

Thanks for your reply. I agree it might be the servo at fault. When checking the logs i was checking a different servo output which confused me initially, after checking based on your response i came to the same conclusion. Thanks for checking it out