ArduPilot Obstacle Avoidance - skydroid gimbal

hi i have install the following skydroid gimbal with laser sensor:
in mission planner view - can see it detect obstacle - (in the mission planner radar - i see relevant distance).
but when i fly my pixhawk copter in loiter or stabilize mode - the drone wont stop/slow before obstacle.

please advise

thanks

1 Like

Did you activate BendRuler?

Hello @bilbi

I am really not sure if it works also for stabilize… but in Loiter it should work. As you said you are seeing reasonable distances in the proximity UI of mission planner, I gues your proximity sensor is properly setup, so I would double check the AVOID_ family parameters. Check if you enabled it for use with proximity sensor (AVOID_ENABLE = 2, bit 1 ON for proximity sensor based avoidance), and AVOID_MARGIN sets the distance it will try to keep from obstacle in GPS modes like Loiter. For non-GPS modes, set the proper AVOID_DIST_MAX parameter). Finally, AVOID_BEHAVE will tell if your drone will slide along obstacle or simply stop. Let me know if it works.

@JDANILOM the path planner is used only in automatic missions like Auto, Guided and RTL, but do not act in more manual flight modes.

1 Like

If you have any doubt, please post your parameter list for more detailed analysis of the problem.

It could be a problem with the 1MB flash of the FC. @rmackay9 says that even a simple stop doesn’t work on 1MB FCs. I’ve been trying to get it to work with a rover FC omnibus 1MB and a lidar for about a year, but using the custom firmware server doesn’t work either

1 Like

Hello, I cannot find a description for the above camera. How do you connect the lidar? SCL SDA or RX TX?

1 Like

I also bought this camera. And there were no instructions included. Maybe someone post it?
Thanks