Ardupilot Compass calibration finishes early in mission planner. Flies but drifts badly

I am a newbie. I have a tarot 680 with ardupilot . It does fly but not well. It tilts down and drifts west and south in stabilize mode. Altitude hold makes the drone fly up and then hold for a second and then drop and then fly up again. Loiter makes the drone fly away to the west.

When I try to calibrate the compass via telemetry and mission planner the dots appear and it does the calibration on different axis but after about 1 minute of calibration it finishes really quickly . it never gets more then 600 points of calibration.

Please help. Im on the verge of selling this and going dji naza.

Ive swapped compasses/gps modules, flight controllers , reset flight controller and reinstalled mission planner and issue remains.


  • Did you auto trim your aircraft (Seems you didn’t)

  • Did you calibrate the accelerometers (Level and 6 points calibrations?

  • Is your CG properly set up?

  • What parameter did you choose when doing your compass calibration

  • Did you had the main battery installed while doing the compas calibration?

  • Which hardware are you using? (Pixhawk or equivalent?)

  • What motor / propellers battery are you using?

  • Is your mission planner version is 1.3.48 build 1.1.6330.31130?

  • What version of Arducopter are you using?

You ask for help, but don’t provide details required to help you…


P.S. Same size aircraft flys beautifully without any problem. (FYI). :slight_smile:

thanks for the response. Im getting pretty desperate.

I have a Radiolink at10 transmitter and receiver.
Ardupilot 2.8 with external compass.
I did the acclerometer( nose up, nose down, left, down and right)
did compass Calibration using Telemetry
running mission planner 1.3.45 build 1.1.6286.16738
ardupilot v3.2.1

motors - ax-2810q kv750
1238 props.
afro esc 30A
quanum gps /compass.
battery is mounted bottom center of drone pointing north

For parameters I chose external compass, obtain declination automatically, automatically learn offsets, externally mounted, ROLL 180,

I did auto trim.
FYI it flies better in stabilize but is uncontrollable and unpredictible in loiter and altitude hold.

  • Using this flight controller isn’t the best for sure.
  • Why? Because you can’t use the latest software due to limited memory
  • How to improve with a “tiny budget”? $60 32 bit Pixhawk compatible
  • On this frame, the external compass /GPS doesn’t seem to be aligned with the flight controller?
  • Frame vibrations are your enemy. How did you isolate the frame controller?
  • Instead of using parallel outputs from your receiver use a single serial link from the receiver to the flight controller.
  • it looks like you kept all the red wires from the ESC!? Remove all of them except one.
  • cables floating without cable ties is a recipe for disaster.

Many other little things, but this should make your aircraft happy.
Perhaps contact me privately as many other issues here aren’t of general interest.
Where are you located?


Sooo. I made some changes and it flew well. Stayed stable in loiter and was great.

i installed apmplanner 2 and did the compass calibration and then it flew well. Better then its ever flown before.

I still dont know why but its flying completely different. It actually flies like it should. Im going to do a 2nd flight and confirm that its good.


I have exactly the same problem using APM arducopter.
I have calibrated everything but compass calibration finishes very quickly using mission planner.
The quadcopter is very unstable in stabilize mode almost impossible to lift it and control.
When I tried Alt hold it fliped and fell upside down.
When tried loiter it started going high.
Did you solve the problem only by calibrating the compass using APM Planner 2?