Servers by jDrones

ArduPilot APM 2.8 cannot get both motors to run

I am a beginner but after a lot of work have got my tank using skid steering to work with a radio controller and receiver, the ardupiltot is driving two brushed motors through two hobbyking esc. PROBLEM. If I connect a battery to the left train all works it powers the pilot the receiver and the motors which run properly from the transmitter left control. If I disconnect that and connect the right it all works fine too. But if I connect a battery to both esc then only the first one connect works. So to summarise I can get both wheels/tracks turning back and forward correctly but only one at a time when i try to do both the last one connected doesn’t work. Any ideas and help appreciated

Do your ESCs have an integrated BEC? If so, do you have the red wires of both ESCs connected to the APMs servorail? This might cause the second ESCs not to initialize correctly/at all, because the second ESC gets power from the servorail instead of delivering it. Remove one red wire from the servo connector and try again.

OK I think they do have BEC. The way its configured is shown in diagram they are both matched 1060’s now

I might not be getting some things here. In the headline for your other thread you wrote “Pixhawk 2.4.8” and then it was an APM 2.x. Here you wrote that you are powering both ESCs with seperate Lipos, but the picture you posted shows one lipo and a power distribution. Could you please clarify which hardware you actually use and how it is setup?
And we should keep it all in one thread.
By your reply to another thread, I guess you are using an APM 2.8. This hardware is not supported anymore for years now. The latest ardurover version is 2.5.1 beta. Ardurover has changed a lot since then, so any information in wiki will most likely not apply. My advice would be to get some modern supported hardware and save yourself a lot of hassle and frustration. The vendors selling this old hardware are ripping people off, in my opinion.
https://ardupilot.org/copter/docs/common-autopilots.html

Hi Sebastian, what you have seen there is an evolution of design as I learned. So yes rather than trying to fit a battery for the APM and 2 for the motors I realised a distribution panel would work. I have a pixhawk as well but consistently in trying to run planner the APM works better. Thepixhawk seems very flaky to me, one day you plug it in and it seems to work up to a point. The next day you go back and it cannot connect. Its the same project but I got frustrated with the Pixhawk and bought this APM 2.8 mega from Unmanned Tech who assured me that it was a) the latest and b) fully supported by rover. I’ll lok at your link though and see what I can do. I will also retry the pixhawk which should run. If not wanting a two motor rover with skid steering which of that long list would be the best start?

Ok, that clears things up. The Pixhawk should be your first choice. If you have problems connecting to it, try another (high quality) USB cable. There should be no need to buy another flightcontroller. Which “planner” do you mean? Missionplanner or APMplanner? APMplanner was last updated in 2018, if I am not mistaken. In the world of software, this qualifies it as abandonware. As a modern version of Missionplanner does not (fully) support an obsolete APM 2.8, APMplanner will not support the most recent versions of the ardupilot firmware on the Pixhawk.
Why unmannedtech recommends a APM 2.8 as the latest and fully supported hardware is beyond me. This is simply not true. For 35GBP you can get modern 32bit hardware capable of running ardupilot.

OK I went to ardupilot rover and tried to download firmware to my pixhawk 2.8 . My choices appear to be cube, fmu2, fmu3, mrox 2.1, pix 1 and pix 1-1m. None of these seem to match the list of “supported” flight controllers except maybe cube. Its very confusing pix 1, pix 1-1m whats that all about? I didn’t think it supported old pix anymore? This is the list from the docs but this does not make sense in terms of the offered firmware.
Open hardware

The original Pixhawk was manufactured by 3dr and is no longer available. The mro Pixhawk (2.4.6) is the official replacement. The Pixhawk 2.4.8 is a “clone”, but since the pixhawk is open hardware, anyone can produce it. The correct firmware should be fmu-v3.

thanks I would not have guessed that from the available list. I’ll reload firmware and try again.

Oh sorry I am trying Mission Planner. Qcontrol works better I find, but it does not support my next step which is GPS waypoint planning. At this point I would be just happy to get it working with my Radiolink T8FB like a normal RC tank.

Qgroundcontrol and Missionplanner are both fine. There is a third GCS software called APMplanner, that did not get updates for a while and since you just wrote “planner”, I assumed APMplanner or Missionplanner.
I use Qgroundcontrol to do waypoint missions from my Android tablet. This should not be a problem.

OK I took Sebastian advice and switched to the Pixhawk. Do you know I spent 20 minutes not knowing how to arm. Its an obscure little switch should be a great big red button on home page!. Anyway attached working (so far) layout
Thanks everyone who spent time with a newbie idiot like me. robbie layout pix.pdf (39.8 KB)

OK on this I just think its not clear unless you do this all day. How was I to know fmu3 meant pixhawk 2.4? Also no sign in the downloadable firmware of most of this list so i am not clear do they work? is the drop list definitive? If so what would for example a CUAV nora do? what is Pix 1 and pix 1-1m? there is no explanation anywhere I can find. I got it working eventually but hours spent going through docs (I don’t suppose it’ll hurt me as I do need to understand), also hours gleaning like nuggets from forums. If I knew what I was doing i’d volunteer to help with docs just so another newbie could get started.

Ardupilot is an open source project. There is no support hotline to call, unfortunatly. If you have questions that the wiki, goolge etc. do not answer or are unclear about, just ask here in the forums. It may take a while, but usually someone is able to help you. The wiki got a lot better recently, but some pieces of information are old or just not there. It is an ongoing effort.

The first versions of the Pixhawk 1 had a hardware bug, making only 1M of flash usable > pix 1-1M.
The list of available flash targets is long, because ardupilot is no longer only supporting its “own” hardware, but a multitude of cheaper boards, too. If you want to know what the differences between the different autopilots are, you will have to read through their discriptions/manuals.

You can disable the safety switch by setting BRD_SAFETYENABLE to 0. It was added as an additional safety layer, so no one gets his fingers cut by suddenly turning props. This is not a big risk with rovers, so none of my rovers has a safety switch.

thanks. I will come back when its running around the patio. The on to the next challenge waypoints!

OK this is the tank running around my patio using rc transmitter so far. Next challenge waypoints
LINK TO ROBBIE

Cool, you got it working!
One thing, do you have the compass from the GPS/compass modul connected? If so, the cable coming from the module should point to the back of the rover.

Ok thanks will try to do that, it just rotates so will have to try to strap it. Downloaded three waypoints and went outside but it will not start, I can use the transmitter and it works so its not going to auto and using the waypoints but again stumped by instructions that say use mode switch on transmitter. What mode switch? Why does it need a transmitter to run waypoints?

Auto mode should be the last mode to use. First you will have to tune steering and throttle in acro mode, otherwise you will most certainly not get a good result in auto mode. During the first uses of auto mode (or guided) further tuning of the navigation controller may be necessary.
Ardurover does not need a RC transmitter to operate, but it makes setup and tuning much easier. If you have a smartphone, tablet, laptop, you can use those to control the rover. This will require some sort of wireless telemetry. I use wifi on all my rovers, either with a companion computer or a ESP8266/ESP32 MCU. There are other options as well, like serial 433/900MHz radios, etc.
Ardurover supports six “flight” modes, you can select by a transmitter switch. If you only have a Desktop PC, this will be the way to tell ardurover to start following a mission. Setup the flightmodes in MissionPlanner/Qgroundcontrol and make the last one “Auto” mode. You can also use other switches on your transmitter, to select certain flightmodes seperatly (and do other things). I always have a 2 position switch set to “Hold” mode, in case something goes wrong, for example.

OK thanks, I do have rc transmitter obviously not set up right as I did not set up a mode switch so will explore that. As a test I set INITIAL_MODE = 10 which should have set it to power up in auto. I used the pixhawk safety switch to arm. But it just sat there. I picked it up and walked around in case maybe it needed a GPS lock to start but the GPS was all green and I had tied the cable as you suggested. Nothing happened.On my Radiolink transmitter there are two switches labelled chan 5 and ch 7 so will try to get them to control mode.

Servers by jDrones