Ardupilot 2.8 balance out while lifting

Hi, I got my Ardupilot 2.8 and I built my quad on F450 with 1000kv motors. So the configuration is

  1. APM 2.8 (ardupilot)
  2. A2212//13T 1000kv motors
  3. 2200 mAh 11.1 Lipo
  4. APM GPS with compass
  5. Flysky 6 channel radio

This is my second quad, first was on CC3D and it worked well. I got APM because of its flight planning option. But now even its not lifting in air with balance. Either goes backward, right side and I am afraid to lift properly as it could damage propellers.

I am attaching its bin/log file can someone please take a look and let me know what I did wrong. It should hover perfectly as it is in many videos. I tried it in my backyard.

I have to complete it before September ends.

Can someone please help me…

Thanks in advance

Farhan (1.7 MB)

If you have calibrated everything and done all the pre flight checks correctly it most likely to fly fine.

If you are too timid in taking off and you have little RC experience (you said this is the second so you should be ok) the ground effect will unsteady the copter and it will most likely tip.

Try just getting it to a meter above ground in one action.

If you are flying multi rotors you can’t be afraid of breaking props, goes with the territory :wink:

yes I have done all pre-flight checks, but why its not taking off smoothly like in other videos. There is something wrong in setting or missing. I have attached my logs for someone can read and finds the problem. This is my first APM project and still learning new things.

Make sure you have compass external in Mission Planner.
This will automatically set the compass orientation at ROLL 180 - this is normal.
Make sure the external compass is enabled with the jumper near your GPS connectors (see the following)

If not already done, take the jumper from INT and move it to EXT.

If you used the wizard, forget it.
I learned to do it manually.
Under mandatory Hardware, calibrate in this order:
Accelerometers (bottom green button first, then the top)
Then everything else.

OH, and with the compass…make sure east is east and west is west.
Don’t just see north pointing north and think you are OK.

I see only very little yaw error. But I see oscillation in pitch and roll, with quite a bit of difference between desired and actual. That would tend to indicate that the Stabilize PID’s are too sensitive for your 'copter. However, it also looks like you are flying in ground effect, which is an inherently unstable place to be.

If it was me, and I was afraid of it, I’d set the MOT_SPIN_ARMED to 0 so the motors can be shut down in flight if discontinuation of controlled aviation is experienced. Then adjust the Stabilize PID’s down to a more sluggish value (you have to guess). On a windless day with plenty of room, take off and apply enough throttle to get at least 2-3 meters altitude in one shot and try to hover it and see if you got control of it. If you experience loss of control and it’s gonna crash simply pull the throttle to descend rapidly, and with the throttle at idle it will stop the motors before the props hit anything.

With MOT_SPIN_ARMED set to 0 you can only stop the motors in flight in one of the non-altitude controlled flight modes (Stabilize, Acro).

Hi thanks for suggestions. I fixed many things except MOT_SPIN_ARMED

I flew this at 3 meters and now it is more stabilize. Again a problem, I tried to use auto-tune and as it was 3 meters high, I turned Aux switch 1 to Altitude mode. Suddenly it gained speed and height and went almost 30 feet high, fortunately I was at the flying club alone, I tried to switch off the Altitude and throttle low but nothing happened. Then I switched off Altitude and disarmed, it went down like a shot duck. I had lot of expectations from Arducopter but its good in manual mode and bad in all other modes. This is the same behavior third time. I am attaching the bin file. Please take a look and let me know did I do something wrong? Sorry for so many files, all belong to one day in 30 min. Dont know which one is good so all are here.

2016-10-03 12-15-33.bin (38.7 KB)
2016-10-02 18-12-36.bin (23.2 KB)
2016-09-25 16-27-05.bin (207.8 KB)
2016-10-02 18-06-06.bin (156.8 KB)
2016-10-02 18-58-35.bin (473.9 KB)
2016-09-20 18-58-46.bin (304.2 KB)
2016-09-20 18-42-23.bin (294.9 KB)
2016-09-20 18-48-30.bin (173.3 KB)
2016-10-02 19-27-05.bin (349.6 KB)

2016-10-03 12-20-46.bin (88.7 KB)

Save your .param file and post it.
There might be something in there causing it.

Last night I was searching and found something very interesting about my problem. This could be the problem. Link is

it says “High vibrations cause the Copter’s accelerometer based altitude and horizontal position estimates to drift far off from reality which leads to problems with alt hold (normally rocketing into the sky) or Loiter (drifting).”

As I switched to Alt hold mode, it made an angle and went up high, luckily one of the propeller detached, I disarmed it and it was wide open so it fell on very thick grass. How do I see the graph of vibrations as in my MPlanner, it does not showing any data for x,y,zQFAOct42016.param (5.0 KB)

Enable the IMU (vibration) logging by changing LOG_BITMASK to 958

Continue to research the vibrations but I found it.
You have the GPS Fence (FENCE_ALT_MAX) enabled at a very low altitude of 10m.
You also have a very small fence circle (FENCE_RADIUS) at 30m.
Once you hit either of those, you go into RTL that launches it to an altitude of 300m (RTL_ALT is set to that so change that to 50).

Oh just a minute, I will send them back to you corrected…

Starting at the top:
ANGLE_MAX 3500 to cut the wind better
ARMING_CHECK 1 to check everything
CIRCLE_RADIUS 0 to be controlled with auto mission command LOITER_TURNS
CIRCLE_RATE 7 for smoother circle.
FENCE_ENABLE 0 to turn it off
FENCE_RADIUS 300 when needed
FS_GCS_ENABLE 0 when ready
FS_THR_ENABLE 2 continue with mission
MOT_SPIN_ARMED 0 don’t deed it running

Here is the corrected file:
CorrectedQFAOct42016.param (5.0 KB)

Take it slow and easy to get used to it.

RTL_MAX = 300 centimeter not meters

I tried to limit the fence are as sometimes I try to fly in my backyard, even at flying club area,its not very big and other people also flying so want to keep it very small just to test first every thing is working fine. But really thankful to you for this. I was really disappointed from it.

Hi pmshop, Chris,

Thanks a lot for your nice suggestions. I have made some changes and will
do a quick test coming week. Will let you know the results.



I did fence purposely as it behaves like wild horse so fence could protect
it. Once I almost lost my quad and found 1km away crashed in a parking
empty due to Sunday.

Brother kindly guide me, when i try to fly my F450 it turns on one side badly… i already done with pre flight checks and all that calibrations etc… i’m stuck on it from couple of months… kindly help me bro.

i’m from Hitec taxila, Pakistan…

03136905832 you can text me too brother i’m really in need