ArduCopter not detected when plugged into computer via MicroUSB, drivers will not install either

I am building a drone for a class, and the ArduCopter 2.8 board we are using is not detected by APM Planner 2 or Mission Planner, and thus drivers cannot be installed to it. I am at a loss, as we cannot go any further with our drone not detecting to the computer. I have installed drivers manually from the Mission Planner directory, and through Mission Planner, but none seem to work. Any help is appreciated. Thanks.

Arducopter is 3.5.5 if I remember my last update.

  • Why do you use a very old version?
  • On three different computers and two laptops never had a problem. Which windows version are you using?
    If you are trying to use an apm board, do yourself a favour, and forget it as it is fully obsolete. (I do have a handful of these in a drawer somewhere)
    Instead, if money is the sole driving reasoning then use a good clone such as
    PX4Pilot PixHawk 100% compatible for AU$81.00
    Hope this help.

It is the only version of the board we have. Our computer uses Windows 7 professional.

I am not an expert.
Does the LEDs in the board light up.?
What is the COM port assigned to the board in device manager.?
Use another good quality USB cable.

Install Linux, problem solved :slight_smile:

No problem with windows 7. Works a treat. So get yourself a PIXXXX clone. The present software 3.5.5 won’t run with an apm board. If $81 is not a possibility try another hobby I guess… :frowning:

So you are saying that the current software is not compatible with our ArduCopter 2.8 board? As I have said prior, we have tried installing drivers via Mission Planner and APM Planner 2. Is there any workaround you know of? This is for a class and buying an entirely new board when this one was bought new, this year, on the website, is out of the question.

We have used multiple USB cables. The LEDs on the board do not light up. I do not know COM port because the board does not appear in device manager. The only COM port I have seen is COM1, which I believe to be the default.

What Linux distribution would be appropriate to use with this? I know how to install Linux distributions to a USB which I could put into our computer. Would Ubuntu work with the ArduCopter software?

I am not an expert. As far as I know, the board is not getting Power.
APM 2.8 :- last supported firmware is 3.2.1

Yes, it could work from usb, try Ubuntu… At least there is no driver hell or .net mess.

Sorry to say but whomever decided to buy an APM this year did not do his (her) homework. This was mentioned on numerous forums and by all the “dev” on a number of occasions.
There are enormous differences in between the APM and a PIXxxx clone compatible.
So no support will be given to you for a start. V 3.2.1 doesn’t use EKF as the on-board processor is unable to crunch this kind of equations in due time.
Beside there isn’t enough memory on an APM full stop.


1 Like

Yes Sir. But…, if it is for a class, I think, we should’nt nip it in the bud. The bug may bite someone there…!
Pls spare me , if I am wrong.

$, time, responsibility, all matters.
did you get it right ?
do you have a power module & a .lipo to power it?
Can you power it using an ESC…?
I was using an APM2.xx…one of the best boards…
Awarded ?..

OK let’s start over. Nothing wrong with using APM 2.8 and it will work fine with Windows 7.

  1. If you get no lights then the APM is not getting power. Could be bad USB cables there are lots of them or the computer is not supplying any or enough power to the APM 2.8

The drivers are installed by Mission Planner so you must install Mission Planner first.

So you need to get power to your APM first. Use a 5.3v power source to see if external power causes the APM LEDs to indicate power ok. Then worry about getting it connected to Windows and th correct drivers.

If external power does not “light-up” the LEDs then you may have a defective APM.

We get a red and a green light that light up when we plug it into the computer Via Micro USB. We have installed drivers with Mission Planner too, but on multiple computers, the board is never detected as a device.

What is a lipo to power it? I am assuming the board is receiving power via micro USB from the computer as we have some lights illuminated on the board.

When you plug in the usb to the APM you should see the green power light come on. Then a few seconds later the red light should flash a few times. Next the red and blue light alternate flashing. Last the red light flashes.

If you don’t see this the board is either bad or maybe in boot loader mode.

The green and red lights are a go. The alternating blue and red lights do not show on ours but it does show on our instructors when we plugged his in. I think it may be a board issue.

So yours is not actually booting up. Hence it is a waste of time to troubleshoot the drivers.