Arducopter initial tuning and setup - Oscillation issue

Hi Team,

I have been trying to setup my copter with the following hardware. 450 Frame, Blheli 32 Oneshot ESC, EMax 930kV, 2212 motor, 10inch propeller & Pixhawk 2.4.8.

I had been configuring and flown few times (could not achieve stability and reset all the data in the controller and set it new. Attached two consecutive log files flown in Stabilize and Alt hold mode. Have not got stability in stabilize mode at all. Even after adjusting PID values to 50% it was oscillating more. Restore the PID values and flown it in Alt Hold mode for about 30 seconds. Could you please review the Log file and advise what are the possible causes for problem ?

Dont worry about using oneshot, go straight to DSHOT.
First load the bi-directional dshot firmware, download the .apj file from in this link and install that

Then use the Servo page in MissionPlanner to move the motor functions

  • from Servo1, Servo2 , 3 , 4
  • to Servo9, Servo10, 11 , 12

Physically move the ESC wires

  • from Main1, Main2 , 3 , 4
  • to Aux1, Aux2, 3 , 4.

Then use the full parameter list to set these:

INS_HNTCH_ENABLE,1  // write then refresh params to see the rest

With this configuration you should be able to use BLHELI32 Suite via its Betaflight passthrough interface to connect to the ESCs and set these:

  • Low RPM Power Protect = OFF
  • Low Voltage Protection = OFF (rely on the flight controller battery settings)
  • Temperature Protection = 90
  • Motor Timing = Auto

Do another test flight using AltHold, just hover for a while, maybe some gentle movements if everything is OK.
Send a link to that .bin log file.

I think you’ll need to try these PIDs if it’s still unstable


Hi Shawn,
With all modified parameters I could able to connect in Blheli suite. But not able to read ESC. Attaching the screenshot of the error and log file from BLHeli suite. Have seen number of youtube videos and doesn’t get much help.

I have tried it with BLHeliSuite32_32.9.0.3 also. same issue.

Use the latest possible version.
The ESCs need the battery connected too.
Set the Baud rate to 115200 (same as your USB port)
Drop down the port list, and only valid ports will be shown, sometimes 2 ports. Choose one then the other until you find the working one.

Tried all the above and latest version too. Nothing worked out. Was looking for option on transmitter mode but except low voltage protection remaining are not programmable in transmitter mode.
What am i missing… stumbled here

Do you have Blheli_32 ESC’s or not? If so you are using the wrong suite/configurator. Which ESC’s are they?

Sorry its my mistake. The order page says Blheli series one shot but not mentioned about 32 or something else. Here the link of ordered ESC.

Can I continue the programming with this model ? or restore the settings to original ?

If you have already moved the outputs to the Aux channels leave them there and set MOT_PWM_TYPE to PWM. or Oneshot. No need to use BLHeliSuite for anything just calibrate those ESC’s the old way.

Or better yet replace those with some BLHeli_32 ESC’s.

Thanks Dave for input.

I have already moved the outputs to Auxiliary. So I will keep it as such. Should I restore the below parameters to default

I will try in future to go with BLHeli_32. I have just ordered them.

Will try this and fly over this week end and seek for support if needed. Thanks for all your support.

It probably doesn’t matter but set them back to 0 anyway.

Hi team, does ardupilot support blheli_s passthrough ? Im trying to flash bluejay in my esc do that rpm filtering can be used. The wiki documentation days blheli32 and blheli_s are supported.

Hi Shawn,
I made two fly in Alt hold mode. Attaching the log file for reference, Could you please advise if any parameters to be updated.

Sorry to have wasted your time trying to get DSHOT going - it would have been worth it if only those ESCs really could do it. Pity about the false advertising. At least now you know what to do, and the copter is almost ready for it when you upgrade to a 4in1 BLHELI ESC.

In the second log there seems to be quite a bit of lag between desired attitude and actual attitude.
Maybe it’s the HNOTCH being set to ESC RPM (when there is none), or the oneshot setting - unsure :frowning:
It didnt seem to be as bad in the first log, but I would change

You could probably try these I suggested earlier too:


See how that flies

Hi Shawn, Thanks for the reply.
No worries. Was able to learn more in this topic regarding blheli_32 which will help me to build it next.
By the way is it possible to connect pixhaw through blheli passthrough for blheli_s ?? I read it in some thread here that the old pixhawk version i think 3.6.8 will support passthrough for blheli_s
The other parameters a mentioned above i will try it out.

Honestly just avoid BLHELI_S if possible. Passthrough should work with BLHELI_S just the same as with BLHELI_32. Research the differences, look at the price differences of the ESCs.
BLHELI_S only exists in order to use smaller cheaper ESCs that were already available and already in use on small quads - where BLHELI_32 could not be used because ir requires a better processor chip. Do you want to take that step sideways, when you can take a step forwards to BLHELI_32 ?

I think DHSOT support was just appearing around Arducopter version 4.0
Also don’t confuse versions of firmware and hardware - it can be very confusing and easily misunderstood.
There are Arducopter versions, like currently 4.3.7 , and hardware like a Pixhawk1.
The confusing thing is some suppliers of the Pixhawk1 clones started calling theirs a version 2.4.x as if their version was better or improved over previous versions - usually it means “we left off even more important parts to make this even cheaper and less reliable”.
There was an Arducopter version 3.6.x firmware but BLHELI wasnt supported at all (as far as I recall)