Servers by jDrones

Arducopter firmware on Lumenier H743 F7 flight controller (MatekH743 firmware target)

Hi,

I’m installing Arducopter firmware on a Lumenier LUX-H7 (ultimate) F7 flight controller.
This flight controller is made to support Ardupilot using the target arducopter firmware : “MatekH743”

This fc has two IMUs : MP6000 and ICM20602

I flashed the MatekH743 arducopter specific firmware via STM32CubeProgrammer succesfully.

Connecting then to Mission planner , i listed the recognized hardware (IMUs) and get this list:

It appears it only sees one of the two available IMUs (the MPU6000 is not listed).

Anyone knows what goes wrong ? Is this a HW def file issue with the MatekH743 firmware ? Should I use another firmware instead ?

Thanks
Hugues

@Hugues,

I’m not an expert in this area but I see from the MAtekH743 hwdef that, as you say, it should support two IMUs:

  • the MPU6000 should be on SPI1
  • the ICM20602 should be on SPI4

I guess you’ve tried with the regular AP Copter 4.0.7 firmware to see if it is any better or worse?

I guess an onboard log file might be useful but I’ll need to ask @tridge or one of the other devs more familiar with this area.

You only have 2 choices. Matek H743 With or w/o Bdshot. I use 4.1.0-dev Bdshot version on a Matek H743. Try that.

Update to latest Mission Planner Beta. What you have (Old Stable) isn’t showing the firmware version on the top task bar. Like this:

I tried as suggested the beta firmware in the two versions : with or without BdShot.
Still doesn’t see the MPU6000 IMU.
I downloaded the latest mission planner, doesn’t show the MPU6000

I verified the documentation for this particular Lumenier H743 flight controller :
-the MPU6000 IMU is on SPI 1
-the ICM20602 IMU is on SPI 4

What target does betaflight use? It would be worth comparing the pin definitions

Betaflight’s target is the same : MatekH743 (supported by Betaflight since version 4.3 =>new. Lumenier indicates to download Betaflight firmware 4.2.x from their website. It means they had to customize the current 4.2 version to make it work)

Any idea whether their changes are open?

sorry, no idea and it’s just speculation on my part that they have made custom changes

FWIW that’s not the latest Beta version of Mission Planner, it’s showing the same version in your screenshot. But it probably doesn’t matter…

I could not find where to download the beta versions of mission planner. I looked in:
ArduPilot firmware : /Tools/MissionPlanner

From the Help Screen in Mission Planner. Hit the button at the bottom.

Something is not right here. The FC you describe is listed on the lumenier website as using an F722 - so will not work at all. Your assertion that this is an H7 board seems wrong to me. I cannot find any reference anywhere to any lumenier FC supporting H7

Oddly I don’t see it on the Lumenier Website either but you can buy one!

Lumenier H7

I suppose the only reason to buy one is for the DJI Air Unit connector.

Ok it looks like a rebranded MatekH743 so I think the MatekH743 target should be fine

I see in the manual a note about if the MCU doesn’t initialize with a link to the Arducopter “When Problems Arise” Wiki page.

H7 not initialize

The Write all zero’s to the Flash space 1st plan…

I don’t think that’s the issue. It seems the 20602 on this board is particularly problematic, tridge thinks mechanical stress degrades it over time. I just wonder whether you have got a bad board.

If the 20602 was bad on this board mission planner would have an issue with it. This MPU works totally fine (according to what I see in mission planner). It is the MPU6000 that is not seen by arducopter/mission planner.
Both MPUs are detected and working fine with betaflight…
So the board is fine. It has 2Mb flash memory. I used STM32CubeProgrammer to first wipe completely the flash memory with zeros as advised in case of problems and then to flash the firmware on it, no issues there at all.

I 'm guessing the Ardupilot precompiled firmware for this MatekH743 target is badly configured somehow (is it the hw def file ? Is it a wrong SPI ?). Unfortunatley that is way above my skills to dig into how it was compiled. Let’s hope some dev can take a deep dive into it to check it out.

Exactly which firmware did you flash? There is no issue with the hwdef and its clearly identical to the matek board

I flashed the stable, latest and beta versions of MATEKH743 targets (both with and without BdShot). All gave the same result : it works fine except the MPU6000 is not seen and not shown in the HWID screen in mission planner

It’s working fine on all 3 version of the Matek H743 boards. There are examples of all of them on the forum here.

Servers by jDrones