ArduCopter BLDC No Response[SOLVED]

I have completed all calibrations including ESC & Flight Mode configured.

Tried with both options Arm-Check Enabled and Disable.

In mission planner, it’s showing that ARMED. But the BLDC is not rotating.

Pixhawk V2.0 firmware 3.5.4

Tried with old firmware 3.4 and new 3.6. Same problem.

Pixhawk gives Green color.

Someone please indicate the issue and troubleshooting methods.

Either a cable is misconnected, or the armed throttle speed is set too low.
Did you calibrate the ESC ? did you run motor tests ?

Did you notice the word (Safe) in the lower left corner of the HUD? This means the safety switch feature is enabled and you did not press it yet. If you do not have a switch connected, you have to set the BRD_SAFETYENABLE parameter to 0.

I have checked the cable connection. I have doubt with the ESC BLDC connection to the pixhawk. I connected only White wire(Signal) and neglected the Black and Red(But connected one Black and Red). From 1 to 8, i used 1 to 4. If there is any correction in this connection, please tell me.

What is the armed throttle speed Parameter name in mission planner to change the same?

I cannot calibrate the ESC with pixhawk, the BLDC is not responding(It gives continues beep sound).
I have manually calibrated all the ESCs.

Is there any method to solve the ESC calibration problem with pixhawk?

About the motor test, where is the option to do so?

I have the safety switch connected with pixhawk, several times i pressed the same. But same response for BLDC. It’s showing ARMED, but BLDC continue beep sound.

Did the (Safe) message disapear after you pressed the safety switch?


After the long press, it’s only showing ARMED.

Thank you very much amilcarlucas & Sebastian Schürmann.

This issue got solved.

I disabled the safety switch and did ESC calibration manually with the RC Transmitter & Receiver.

Also tried the calibration using Raspberry Pi 3 separate program.

Now the Quad-copter is ARMED and all the motors are responding for the RC.

make sure all GND signals are connected as well. connecting a single GND might cause problems.