Servers by jDrones

ArduCopter 3.7 object avoidance with optical flow on loiter mode (indoors)

Hello,

I have a copter and am trying to do object-avoidance in doors. I have two lidars, one facing down in use with the optical flow sensor and one facing forward, their orientations are 25 and 0, respectively.

The optical flow sensor works great, because the copter is able to hold its position indoors in 3D space. Also, I can see the data coming from the front sensor is correct on mission planner.

However, for some reason, whatever the value of AVOID_BEHAVE is (0-1), the avoidance is not working properly. It does not really stop in loiter, and the slide behaviour is kind of inconsistent. What could be the cause ?

Thanks !

Use copter 4.0 and post the logs

1 Like

Okay, tried 4.0 but did not work. The result was the same.

However, I found out that the minimum value of AVOID_DIST_MAX parameter is 3.0 (from mission planner)

It is shown as 1.0 from the official parameter list web page. The setting for 1.0 (which was mine) does not work, and if I change it with 3.0, the system works as expected.

Thanks!

Servers by jDrones