Servers by jDrones

APSync with Nvidia Jetson TX2 Dev Kit + Pixhawk


(Astern A) #1

Hey Guys,

I have successfully integrated a RPi v3 b+ model to communicate with Pixhawk 2.1 (the cube).

http://ardupilot.org/dev/docs/raspberry-pi-via-mavlink.html

Now I have purchased a Jetson TX2 dev kit and I wish to connect (for now) the entire dev kit to the pixhawk.

(Flashed with Jetpack 3.3)

Initially, since both the RPi and the dev kits both have UART and are both ARM, the setup should be similar however it does not seem to work. (followed the manual precisely except for step “Disable the OS control of the serial port”)

Important: The Jetson, when connected to the pixhawk and powered on, would not load up and constantly reboot. any idea why this is happening?

In addition, I saw that it is possible to flash the TX2 with an APSync image, however, I have a few concerns with this hopefully I could get some answers:

  1. How does APSync affect the other aspects of the Jetson without the interaction of the Pixhawk? Will it just create the access point and the Jetson behave as though nothing else happened to it?
  2. Is it possible to disable the access point and data flash loggers? I have an RF device connected to the pixhawk and I just want the TX2 for video processing before sending it to the ground.

Any advice/ help is greatly appreciated!!

Almog


(peterbarker) #2
  1. How does APSync affect the other aspects of the Jetson without the
    interaction of the Pixhawk? Will it just create the access point and
    the Jetson behave as though nothing else happened to it?

APSync is layered on top of the image provided by nVidia. You can see all
of the changes made to the image in the ardupilot/companion repo. We do
fiddle some bits and pieces - logging in as the apsync user, that sort of
thing.

  1. Is it possible to disable the access point and data flash loggers? I
    have an RF device connected to the pixhawk and I just want the TX2 for
    video processing before sending it to the ground.

You can comment stuff out in /etc/rc.local to stop stuff running.

The access point you will need to use “nmcli” to disable. Possibly
something like:

nmcli connection modify WiFiAP connection.autoconnect no

Peter