Servers by jDrones

APSync R.Pi3 setup issue


(Anthony Short) #1

I’m working through the setup script in Raspian/1_create_base_image.txt. It all worked fine until 6_setup_video.sh tried to install gstreamer, when I got the error below. I’d really appreciate a pointer on how to resolve this.


Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gstreamer1.0-omx-dbg : Depends: gstreamer1.0-omx (= 1.0.0.1-0+rpi12+jessiepmg) but 1.10.4-1+rpt2 is to be installed
E: Unable to correct problems, you have held broken packages.


(peterbarker) #2

I’m working through the setup script in Raspian/1_create_base_image.txt. It
all worked fine until 6_setup_video.sh tried to install gstreamer, when I
got the error below. I’d really appreciate a pointer on how to resolve this.

Might need:

apt-get update
apt-get dist-upgrade -y

That often fixes these issues.

The following packages have unmet dependencies:
gstreamer1.0-omx-dbg : Depends: gstreamer1.0-omx (=
1.0.0.1-0+rpi12+jessiepmg) but 1.10.4-1+rpt2 is to be installed
E: Unable to correct problems, you have held broken packages.

Also try using aptitude in place of apt-get; it sometimes does better
('though it sometimes toasts your system).

Also check for held packages:

apt-mark showhold


(Anthony Short) #3

Thank you for the suggestions - unfortunately no luck with any of those, and no held packages. This was a clean raspian stretch-lite image. Anything else can I try other than starting over?


(peterbarker) #4

Thank you for the suggestions - unfortunately no luck with any of those, and
no held packages. This was a clean raspian stretch-lite image. Anything else
can I try other than starting over?

I recollect hitting this issue (after producing the most recent image).

I thought it was “aptitude install” which got me past it :-/


(Anthony Short) #5

That didn’t seem to do anything and I’m still getting the error.

Interestingly this problem seems to have been around on and off for a couple of years, for example:

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=113459

Since you ran into this after building the most recent image, I’m wondering if the recent image is based on Jessie and the problem appeared in Stretch (which is what I’m using)? Does that sound right? If so maybe I should just start over using the Jessie image.


(Anthony Short) #6

I did a clean install using jessie rather than stretch and gstreamer installed fine.

I did run into another issue - a couple of compile errors installing jinja2, but the package apparently installed ok so maybe that is benign for apsync?

I now have a complete working r.pi apsync built from the scripts.


Installing collected packages: cherrypy, jinja2, portend, jaraco.classes, cheroot, MarkupSafe, tempora, pytz
Compiling /tmp/pip-build-2RLupl/jinja2/jinja2/asyncfilters.py …
File “/tmp/pip-build-2RLupl/jinja2/jinja2/asyncfilters.py”, line 7
async def auto_to_seq(value):
^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-2RLupl/jinja2/jinja2/asyncsupport.py …
File “/tmp/pip-build-2RLupl/jinja2/jinja2/asyncsupport.py”, line 22
async def concat_async(async_gen):
^
SyntaxError: invalid syntax


(peterbarker) #7

That didn’t seem to do anything and I’m still getting the error.

Hmph. One interesting test would be to take the current image and try an
ap-get dist-upgrade and see what happens. If it completes then it says
two things - that the problem can be overcome, and will give you a list of
packages which work well together.