Servers by jDrones

Apsync fails on Jetson TX2

(mtbsteve) #1

I have a TX2 with Jetpack 3.3 installed according to the Nvidia instructions plus the Auvidea J120 board changes and everything was perfectly running on my TX2.
I then tried to install APsync according to the instructions at http://ardupilot.org/dev/docs/companion-computer-nvidia-tx2.html
I am using the image: http://firmware.ardupilot.org/Companion/apsync/beta/apsync-tx2-201807301326.img.xz

The flashing went smooth w/o errors. The Jetson now powers up giving me the newly created apsync user to logon on the start screen.
However I cannot logon to the Jetson anymore. Regardless if I try the newly created apsync user or the existing nvidia or ubuntu users on my TX2, the logon fails with a pop up “System program problem detected” and gets back to the logon screen.
The startup sequence gives the following errors:
https://youtu.be/H9uINh-d0qM


The issue seems to be related to the apsync WiFi changes. Any ideas anyone?

(sn) #2

I was facing a similar problem @mtbsteve
I went through this APSync documentation at http://ardupilot.org/dev/docs/apsync-intro.html and flashed my JTX2 with http://firmware.ardupilot.org/Companion/apsync/beta/apsync-tx2-201807301326.img.xz image which even you have used.

I faced exactly same problem as you have mentioned.

I used a different image and the problem was solved and I was able to log in to apsync user without any
System program problem detected error.

Image I used: http://firmware.ardupilot.org/Companion/apsync/beta/apsync-tx2-201804270923.img.raw.xz

Just extract the archive and rename the extracted apsync-tx2-201804270923.img.raw to system.img and replace the existing file in your Jetpack directory “…/64_TX2/Linux_for_Tegra_64_tx2/bootloader/system.img” and flash the image.

The size of the extracted file is just above 28 GB!

Alternatively, you can login to TX2 using Secureshell (ssh) by simply connecting your TX2 and a laptop to same network. APSync provides a better alternative, it creates a wi-fi hotspot at startup with SSID: ardupilot and password: ardupilot. You can connect to this hotspot and launch the Ardupilot webserver in any browser via. http://10.0.1.128.

Once you’re connected to the hotspot you can access the files on your TX2 using SSH. The home folder consists the configuration and startup files for the webserver and other services.

Command:ssh apsync@apsync / ssh apsync@10.0.1.128
Password for ssh login: apsync (same as username and applies for the users nvidia and ubuntu too.

(mtbsteve) #3

Thanks for your feedback!
I used the latest Apsync version as of July 30, 2018 which basically corrupted my Ubuntu image on the TX2. There is no network, so no possibility to ssh in from another computer.

Before I re-image my Jetson and try the Apsync version you used, could you let me know the Jetpack release you are on?
I have Jetpack 3.3 installed and had believed that the April 2018 Apsync version is for Jetpack 3.2 only.

(sn) #4

@mtbsteve I installed Jetpack 3.3 as mentioned in the APSync documentation at http://ardupilot.org/dev/docs/apsync-intro.html and then flashed the April 27, 2018 APSync image.

(mtbsteve) #5

ok - when you then flashed the April 27 apsync raw image you went actually back to Jetpack 3.2.
This is not an option for me.