@bnsgeyer @ChrisOlson

I just received my Holybro PX4_2.4.6 (http://www.holybro.com/product/pix32pixhawk-flight-controller-with-power-module/)
Unfortunately I see on the box “APM firmware” when I guessed to have purchased a Pixhawk.
I have trouble uploading Copter through MP, because MP doesn’t recognize the board type (I guess that MP is not compatible with APM).
So far no assistance received from Holybro where I asked for support and clarification.
Before raising a complain to the seller, I would like to understand if I can solve by my own (shift APM to Pixhawk).
Any help will be appreciated a lot!

The module you depicted IS a pixhawk “kind-of” module. It IS compatible with MP.
And btw MP is also compatible with older APM boards.

So please complain, it must work.

I tried to update the firmware through Mission Planner (1.3.68), however I’m getting the message “can’t detect your board version”.

By the way, the Pixhawk can be connected to MP for all the operations.

Reading on Ardupilot (Solved: Mission Planner cant detect your board version) I had to select Force Bootloader option.

Then I selected as board Pixhawk P4 v2 and finally I was able to upload the latest Copter firmware, BUT…

When I connect it to MP again, I get Pre-arm worning check firmware or FRAME_CLASS.

I have set frame class 11 as it is a tandem helicopter.

So, to test, I loaded the last version of Fixed wing fw, still through Force Bootloader option.
Load accomplished and no more pre arm warning.
Now, I’m even more confused: is it a bug in the helicopter fw or my board has problems?

Thanks for helping.

No. - load copter, connect, and go into initial config. Select your frame type at the top and lower in the window. Save parameters and power cycle. next connect should have no pre arm warning for frame class.