APM Planner v2.0.25 cannot install firmware

I bought a pixhawk from Holybro that shipped with the PX4 flight stack. I would like to install the ArduPilot flight stack, particularly the latest Arduplane.

When I plug in the usb in order to get to the installing firmware page, nothing appears except a white screen with the ability to select the firmware upload com port. I’m not connected to the board but when I select the port, nothing changes then either. Do I need to change a setting in APM possibly?

I came across this post that sounded like the same problem. I’m on a mac as well running High Sierra. The last response sounds like it’s a problem with which server APM was pointing to in order to get firmware. He says the problem was fixed back in March/April with the official build. Is this correct, or do I need to build the software from the GitHub repository?

Any pointers on this would really help.

Try using QGrounControl to install Arduplane. After its flashed you can then use APM Planner 2 for configuration if you like.

I started with QGroundControl but tried APM because QGC could not find the specified firmware download location (verbatim error message). I then tried to install a custom firmware by downloading the Arduplane firmware and installing it as a custom firmware. My board ID is listed as 50 but I don’t seem to see one for that that on the Arduplane download link.

Is this the correct repository/software for the board I have?

Edit: I also found this set of firmware for a board with an ID of 50 but QGC only allows me to install .px4 files.

Try v2.0.26:

I think you may have to use the fmuv5 beta firmware for that board but I’m not sure.

I tried removing the v2.0.25 APM and installing the beta v2.0.26-rc2. I still had a blank screen when I tried to install the firmware.

I’ve downloaded the fmuv5 beta firmware but QCG doesn’t allow me to select any file except a .px4 file. I’m looking at this firmware, which doesn’t have a .px4 file.

I see the dilemma. Find a Windows machine and use Mission Planner?

There are no px4 firmwares for the newer boards like the PixHawk4.

At the moment the firmware location is here for the latest beta


At the moment neither QGC or APM Planner or even Mission Planner deal with the firmware for these, but things will change rather quickly.