APM Planner 2.0.25 Newbie Issues (mac)

Hello I’ve recently made the switch from racers to Ardupilot and right out of the gate I’m having issues with downloading and installing firmware. I watched a few vids. and APM Planner doesn’t look like anything in most of the vids.

The first problem is that it won’t download any firmware. It seems be a path problem… I’ve looked around in Ardupilot.org firmware section and the paths that APM planner is looking for firmware doesn’t seem to match. APM planner gives me an Error 203…

Because of the above issue I manually downloading the firmware for a hexacopter Im building although Im not sure its the correct version… I click on “Install Firmware” I get a blank white screen… No Icons listing craft type like I see in all the vids. I have tried an older version of APM Planner 2.0.24 and these icons are listed but I have not gone any further for fear of bricking my pixhawk.

I believe all the drivers are properly installed… I have other flight controllers using STM, FTDI, DFU, etc drivers and they all connect fine

Macbook Pro High Sierra 10.13.3
Pixhawk 2.4.8 I think… ( Pretty sure its a clone)

Any help is greatly appreaciated

Hi @Key0nee, it is a known - and already fixed - issue. See https://github.com/ArduPilot/apm_planner/issues/1110
But there was no new build since the fix was committed. If you can build on your own you should checkout the current master - which already contains the fix. Otherwise you will have to wait until @billb will build the next release candidate. Another possibility to work around this bug would be to redirect the URL APM-PLanner is using (http://firmware.eu.ardupilot.org) to (http://firmware.ardupilot.org) on your local machine or router.

Thanks Arne,
I’ll setup and learn to build my own… I figured I’d need more computer Kung Fu here in the deep end of the pool… Might not be the right place to ask a followup question but, I have since tried using Qgroundcontrol and it worked great… Can you comment on which software would be better for newbie to work with. Im quite confident I can learn to work with sources to build my own but If any of it requires actually coding, I’ll be stuck.

Thanks again

As I am one of the maintainers of APM-Planner I would say its the best tool you can get :wink: I never tested QGroundcontrol but I would say APM-Planner is one of the best cross plattform tools you can get - especially the log analyzing is state of the art!
But AFAIK Mission Planner has more features as it has a full time maintainer - but it requires dotNet as it is written in C#.

Can you give us examples of the paths that it’s looking for, please?


I probably in over my head here but I have since my first post I installed QT and compiled apm planner from the current master as Arne-W suggested. Since running the new build I can no longer duplicate the problem I was having concerning V2.0.25. But trying to explain from memory it was something like apm planner was looking for the firmware I wanted in /stable/PX4/Copter/ . and I think the actual path was more like /Copter/stable…

Hope that helps and Thanks for the help

This fix was merged here https://github.com/ArduPilot/apm_planner/commits/master and since you built from master you have the change.

The reason this even became an issue was the url for downloading was changed to firmware.eu.ardupilot.org. It was supposed to be firmware.ardupilot.org and the server redirects to the correct mirror. When eu version was no longer valid, the redirects didn’t happen and the FW stop downloading

We will push an 2.0.26-rc2 update (next week) that will have some pre-build binaries for people to download.