APM Planner 2 on Ubuntu 14.04 exist unexpectly


This is my first time using APM Planner, and I have installed apm_planner_2.0.19-rc4_ubuntu_trusty64.deb on Ubuntu 14.04 successfully. But when I run connect to my autopilot (NAVIO2) it crashes with the last few lines:
INFO 2018-02-26T13:13:39.477 “/home/erin/apmplanner2/tmp_audio/Pre-arm_check:_Compass_not_calibrated.wav” file exist, playing this file
INFO 2018-02-26T13:13:39.478 ERROR OPEN FILE: “/home/erin/apmplanner2/tmp_audio/Pre-arm_check:_Compass_not_calibrated.wav”
INFO 2018-02-26T13:13:39.478 STATUS TEXT: 2 : “PreArm: Compass not calibrated”
DEBUG 2018-02-26T13:13:39.484 APM: Text Message rx’d “PreArm: 3D Accel calibration needed”
INFO 2018-02-26T13:13:39.485 “/home/erin/apmplanner2/tmp_audio/Pre-arm_check:_3D_Accel_calibration_needed.wav” file not exist, create a new one
VAL: tried to access cart in -1 type val

I have attached my log file. Please help!


log.txt (72.6 KB)

To begin with, try current build 2.0.25

I also strongly recommend to update to 2.0.25 as the 2.0.19 is not really kompatible with your ArduCopter version. Moreover there have been tons of bugfixes since 2.0.19!