APM Helicopter 2.6 Wiring Help Please

Confused Again, and Thanks in advance for any help/
With Arducopter Traditional Helicopter mission planner documentation I notice there are two ways to wire a APM 2.5 board to inputs, outputs, esc so on. I have tried to included pictures of these layouts ( hope I posted pics right) and I wish someone would tell me which one I am suppose to use?
One setup shows APM 2.5 ch 8 connected to receiver ch3, with ch6 connected to ch7, and ch7 connected to ch8?
The other setup shows all ch on APM straight across to receiver channels1 to 1, 2 to 2 so on
Not sure which is correct?
Thanks for any Help or Suggestions


APM 2.6 Ver3.2.1, 450 Trex clone, tarot FBL head, Emax digital servos, (APM is mounted under belly of heli)Flysky Th-9X, and Flysky 9ch receiver

Hi William,
Good to hear you are still working on it there.

The top image in your post is for a Futaba receiver/radio system, which has different channel mapping. The bottom image in your post is for a conventional receiver/radio that has regular channel mapping.

What I would recommend (assuming you have a non-Futaba radio) is to use airplane mode in your radio, and not helicopter setup. The reason is because most radios will output a mix for flying helicopters, and with ArduPilot the mixing is done in the flight controller. So if you have a non-Fubata system then the straight-thru connection scheme should work, shown in your bottom image. And using airplane mode in the radio the channel mapping will be correct.

If you have a Futaba system, the top image showing the cross-overs is necessary.

Sorry - I just looked closer at your post and see you are using a FlySky 9ch. So use airplane mode in the radio and use the straight-thru connection scheme shown in the bottom image in your post. And it should work fine.

1 Like

Both pictures show a Futaba receiver. Do the docs need updating?

Well, they do need updating. In the second one with the picture of the Futaba receiver showing straight thru hookup, it was used just for illustration purposes to show how to connect a non-Futaba receiver.

Chris
I am really glad you are around and so helpful, Thanks, no local to ask
Truthfully I have tried my Flysky 9X transmitter, set up as airplane with the straight across hookup like second image, and could never get the collective to move with the throttle movement?
I use Mission Planner now with Flysky 9X set up as Heli -heli1 -1servo-no mix with a standard PWM receiver and the cross wiring as image 1 and everything appears to work as it should as I can adjust throttle and pitch curves in transmitter, stabilize appears to be correcting as it should, but not as good as it should, seems like there should be more corrections from the APM? Roll P is turned down to 90 to keep from wobble, Pitch P is 110, much higher is wobble, rest parameters are default for Ver 3.2.1 Heli?
I have flown this setup several times, but it is still only about 50% better than when I was using flybar, still fighting it more than I think I should.
This is when I posted for help with the tuning and also about Alt- Hold and you where good to reply there also.
Thanks again, still confused, maybe will try image 2 again?

Thanks Lars! That should help.

Well, I guess that makes sense, since in heli mode your FlySky radio (I use a FS-i10) should probably have the same channel mapping as a Fubata. But in airplane mode in the radio, the channel mapping should be straight thru and work by default (I think).

Would you mind posting your current param file from the APM? I’m curious to see what the RC mapping is.

Chris
Here is parameter file.Apm Heli 5 21 17.param (5.4 KB)

I know the Flysky 9ch receiver is a standard PWM ?
If you see something I should be or not be doing in Mission Planner that might help controller performance, let me know
Thanks again

1 Like

William, I guess I can see why it works in Heli mode. Channel 6 would be collective pitch, which you have hooked to the #3 pin on the APM. I don’t understand why it didn’t work with airplane mode with your receiver. Unless the RC map for throttle has to be changed for 3 for that. It is currently 8. As long as it’s working don’t fix something that’s not broke.

You have obviously hovered the helicopter. And you still have to do a bit a bit of a “stick dance” to hover a FBL helicopter with a stabilization system. Flybar is rate only. So if you’re in hover and tip the heli ahead by say 5 degrees, center the stick and it just stays at that attitude and goes. The difference with FBL is that when you tip the heli ahead to move and recenter the stick the flight controller should level the helicopter again and it kind of “drifts”. So this makes it easier to hover because it always tries to level the helicopter when you center the cyclic. But myself, personally, have never been able to get used to the “feel” of flying a FBL helicopter in Stabilize. It’s not natural. I pull the nose up when flying, and feed it a little collective and I expect it to climb to a vertical nose-up attitude and it won’t do it. And acro is supposed to be more like flybar but the way my helicopter is tuned that don’t work either. So if I want to fly to have fun I still go to the flybar. :slight_smile:

Your P gains don’t look too bad. You don’t have a compass or GPS so you’re basically just using gyros. Turning up your rate I gains might help with hovering. Most people would use around .35 for those and yours are set at only .1 as shown here below. I would suggest to turn those up by maybe .05 at a time until you get into the range of .3 to .35. They won’t cause a bad wobble. If you get too high you’ll get a sort of softer slower wobble.
RATE_PIT_I,0.1
RATE_RLL_I,0.1

And typical for the IMAX params would be 4400 for most helicopters, which are still at the default of 1000 as shown here
RATE_PIT_IMAX,1000
RATE_RLL_IMAX,1000

If the stick input seems a little sloppy and you want it snappier you can turn up the rate feedforward. Those params are these two below. I would suggest turning them up by .01 at a time to “sharpen” the handling. These won’t cause any oscillation at all - just quicker response to your stick inputs. Typical would probably be in the range of .03 to .06 depending on how you want it to feel.
RATE_PIT_FF,0
RATE_RLL_FF,0

And then your throttle accel might be too high for helicopter. It is currently set to 0.5 as shown below. This will usually make the collective bounce on most heli’s when you go to Alt Hold. I would suggest 0.3 for that.
THR_ACCEL_P,0.5

The last thing I’m wondering about, is your tail holding ok? Or do you have to fight the yaw all the time? If you have to fight the yaw to hold a heading, try turning these up. Yaw I maybe to the .1 to .15 range. And yaw IMAX to 2500. With no compass and just gyros that still should work (I think).
RATE_YAW_I,0.02
RATE_YAW_IMAX,1000

Chris
I am not planning on giving up on the APM, I know it must be possible to make it fly better by all the videos I have seen online, just need the right settings. Right now there are springtime things to do around the house and do not have a lot of time
It would be greatly appreciated If it is possible is there a way I can contact you later for advice?
Also would you or someone else have a parameter file from a working APM 450 helicopter setup?
Thanks again for all your help

William, it will fly fine once properly tuned up. It has been awhile since I flew an APM in a heli. But please don’t hesitate to ask for help.

You can refer to my connection in the diagram.

I have pushed upload button to upload the diagram. If you don’t see it, send me your email and I will email it to you: frankie.wcfung@gmail.com

Hi Chris,

Hope you can help me too, I bought the APM a while ago, and now I finally have the time now for building the APM 2.8 on my helicopter, and now it’s not supported anymore… anyway I want to see it work anyhow…

I basically have the same setup, Futaba system, APM 2.8 and a Trex-450, and connected the receiver to the APM as described above on the first wiring picture and use Arducopter 3.2.1 and Mission planner.
All the controls work fine, except for the throttle and the collective, when I connect ch3 to ch8 on the APM the throttle works fine, but the collective doesn’t, and when I connect ch3 to ch3 on the APM the collective works fine, but now the throttle doesn’t???
It drives me crazy, and it looks like the mixing isn’t working or something, do you have a suggestion please?

Thanks a million in advance!

Likely the problem is that the flight controller is not armed. There is no throttle output until the unit is in armed state.

Hi Chris,

Thanks a lot for the reply, but even when the flight controller is armed there is throttle output but no collective output on channel 3, when channel 3 of the receiver is connected to channel 8 of the flight controller, or when I connect channel 3 of the receiver to channel 3 of the flight controller, the collective is giving output, but no throttle output.

I only have the following connections right now on the receiver to the flight controller :

Receiver Flight controller
1 -> 1
2 -> 2
3 -> 8
4 -> 4
5 -> 5

It looks like channel 3 of the flight controller is not evenly mixed with channel 8.
It took me many evenings already to figure it out and it drives me crazy now, I hope you can help!

Best regards,

It has been a while since I set up this configuration. I think your problem is that you need to make a connection between the receiver channel 6 and the apm input channel 3. APM input channels 1, 2, and 3 are roll, pitch, and collective. We use input channel 8 for throttle but this is usually the setpoint for the ESC. I believe when I set mine up, I used a heli profile in my transmitter and made the pitch curve a straight line from -100 to 100 and I set my throttle curve to just a flat line at the setpoint for my ESC. Be sure to turn off any collective to yaw mixing in your transmitter.
Hope this helps. Sorry that we don’t have more detailed information on this setup.
Regards,
Bill

If I’m not mistaken I think the crossover that needs to be made is receiver 3 -> APM 8 and receiver 6 to APM 3. And use a H1 heli setup in your radio. That should get it working if the radio system is one of the Fubata “H” series systems.

And then do a throttle curve in your radio like Bill noted and use your throttle hold switch to turn it on and off. You may have to adjust the endpoint for the throttle hold because if I remember right, throttle hold is like 1080-1100 pwm and that won’t let your ESC initialize. So the throttle hold has to be set all the way down.

If your radio is NOT one of the Futaba “H” series and has an airplane mode in it, use that instead. In airplane mode you should be able to hook everything straight from the receiver to the APM, and set up a switch to turn Channel 8 on and off for throttle.

I think.

Ojoo
I am using a Flysky 9X radio and Flysky 9 channel reciever that has the Futaba channel order. I set up my 450 heli, APM 2.6, Ver 3.2.1 with the radio on Heli, H1, and the APM to reciever using the cross channel Futaba setup shown top picture of this post. Pitch and throttle curves are setup in radio, have been flying it like this for a year or so.
Thanks to Chris and many others on this forum on tuning and setup help.
Hope this helps

YESSSSS!!! I got it, thanks to all your help and tips and tricks, can’t thank you enough guys!
Now I have to mount everything nice on the 450, and it will be ready for the first test flight, I keep you updated anyway.

Have a great day, mine is already great :grin: