APM Firmware Upload Error: Unable to gain access to bootloader

I’m making a DIY drone with APM 2.8. Last week I was trying the APM while waiting for some connectors, and it seemed to work fine, but today, I soldered the connectors of the motors, and the power module, but I soldered the power module in the wrong direction (+ to - and - to +), the fuse of the Power Module burned out. I was scared if something had been burned, but everything seem to work well, except the APM, that I can’t upload the Firmware.
When I connect the board, it only turns on the green power LED. but my computer detects the board correctly, as an Arduino MEGA 2560. It starts heating a bit, but the same as my real Arduino Mega 2560.
In Mission Planner, when I try to Upload the firmware from “INITIAL SETUP” -> “Install Firmware” -> “APM:Copter V3.5.0 Quad” it shows me a first message, which confirms that I am foing to install the selected firmware, when I click “Yes”, it shows me this message:

This board has been retired. Mission Planner will upload the last available version to your board (AC 3.2.1/AP 3.4.0)

I click “OK” and it starts downloading from internet, and reading Hex, but almost at the end of this progress, it shows an error:

Communication Error - no connection

I was Googleing a lot, and I found a program, based in Mission Planner, called APM Planner. I downloaded and installed it, and again, I did all the process: “INITIAL SETUP” -> “Install Firmware”, and selected COM8, on the right, it showed me:

Arduino MEGA 2560
Arduino LLC (www.arduino.cc)

Then, I clicked the “ArduCopter V3.2.1”, and It showed me:

You are about to install ArduCopter.hex for apm2-quad

I clicked OK, and again, it downloaded the code correctly, but when loading the hex,it showed me an error. Here’s the output:

Started downloading http://firmware.ardupilot.org/Copter/stable/apm2-quad/ArduCopter.hex
redirect to http://firmware.eu.ardupilot.org/Copter/stable/apm2-quad/ArduCopter.hex
Finished downloading C:/Users/Arnym/AppData/Local/Temp/APM Planner.n11068
Opening firmware file…
Hex file loaded: 244418 bytes
Unable to gain access to bootloader

I supposed that it’s a problem of the board bootloader, and I started searching how to fix it, and I found this: https://github.com/ArduPilot/ardupilot/tree/master/Tools/APM2_2560_bootloader.
I downloaded it, but I have Windows, I tried to make it with GNUWin32 and MinGW, any of those compiled the code. With VM Virtual Box, I executed the code, but it showed me:

-------- begin --------
sh: 1: avr-gcc: not found
Makefile:479: recipe for target ‘gccversion’ failed
make: *** [gccversion] Error 127

I don’t know what more to do, any other ideas? Or I have to buy another APM?

OK, one track was broken, and some components doesn’t work. I will buy another…

Hey… So just wanting to clarify… Ended up being your APM that was busted? I’m having the exact same problem and I have been putting off having to purchase one (I’m cheap…)… But I was getting to the point of just doing that. Want to verify that was also your problem and that everything worked once you bought the new APM.

Thanks!

I fixed that problem buying another, one track was broken. But, I had same problems with the new one, and I fixed them by disconnecting a Bluetooth Dongle that was connected to my PC. If you have any wireless component connected to an USB, disconnect them, and it should work.

Hello my friends, sorry for my English but I managed to solve this problem using the mission planner 1.3.75
I simply downloaded the firmware in my case it was for rover as the link ArduPilot firmware : /Rover/stable-2.5.1/apm2
then in the mission planner I went to setup > install firmware > Load custom firmware.
I selected the firmware I had downloaded and it was successful
I had tried to change the version of the mission planner, use the APMplanner and nothing worked, and I downloaded the firmware and loaded it with I explained