APM 2.8 USB problem


I just bought an APM2.8 and I tried to upload ardurover firmware on it. Every time the uploading firmware was getting stuck ending with an error message. All settings for Com port are good including drivers installed showing arduino 2560 driver in device manager. I started to research about this problem and i found this http://ardupilot.org/copter/docs/common-ppm-encoder-apm2x-atmega32u2.html. Have done step by step the same thing and now is even worst. In device manager it is showing "atmega 32u2"as a USB not "arduino 2560 "as Com Port. Is there any chance to bring this little board back to life? Please understand that i’m posting here after I tried a full day all kind of methods found on google. Please understand that my first driver installed was 15 years ago so please avoid dummy answears to this post. I tried with a different laptop that used to show "COM PORT 4"as Arduino 2560 and now it shows as ‘USB’ ATMEGA 32U2’. I’m just stuck … please some advice


the very first question: what was the original error message when the upload aborted?

Seems the bootloader on the Mega2560 is non-operational now. If so, you,ll need an ICSP to program the Mega direcly. Provided there’s an ICSP header for the Mega. (I’m familiar with the Mega2560, but not (yet?) with the ATM 2.8.)

I tried to program it with arduino as ISP using the isp pins on top near USB cable. Using avr dude i don’t know what files to upload because detecting it with AVRDUDE GUI is says atmega 328p not atmega 2560