APM 2.8 Quadcopter motors will not run

This is my first DIY drone project and have hit a road block at the very end of the process. I have reviewed numerous help sites and videos and with the exception of possibly clipping the red signal wire to the ESCs, I feel I have tried everything I can find. The problem is simply that the motors do not respond at all, completely dead.

I went through all the mission planner steps and the radio setup works fine. I even tried buying another APM control board just in case the first one was bad. the signal from the controller to the ESCs is just not happening.

PCB is sending 11.4V to the ESCs, so I don’t think drive power is an issue.

If anyone has any ideas, your help will be much appreciated. I attached some pictures to give an idea of the setup.

Is it armed? Do the motors run using the Motor Test function in Mission Planner? I’m sure you realize the APM is obsolete and there are fewer and fewer people around to help with them. Replacing it with a board that will run current Arducopter would be the best choice.

1 Like

There is a huge list of supported hardware:


Just pick one, some are as cheap as 30 Euros.

I think it is armed, but I am not sure how to check.

The motors do not run with the motor test function. Mission planner gives a version compatibility error when I try. I guess 2.8 is not compatible.

Any suggestions on a board that will run the most recent version of Arducopter? That may be my next smart move. I did not realize how out of date 2.8 is until I started trouble shooting this problem.


In Mission PLanner HUD it will say if it’s armed.

Ah, yea Motor Test probably doesn’t work with APM. I have forgotten a lot about what worked in Copter 3.2.1.

You have 2 directions you can take with Flight Controllers that support Arducopter. FC’s with housings, standard connectors, redundant features, etc. Pixhawks and Pixhawk variants, Cubes, other offerings from Mro, CUAV and HolyBro. Knock-off Pixhawks are the cheap options and Cubes are the common choice for higher quality. Or you can choose more of a bare board approach with the F4 and F7 FC’s. Most of these range in price from ~$30-$50.

If you want a cheap Pixhawk knock-off the 2.4.8’s work. Many will dis-agree and consider them crap but they have worked for me. For the F7 board the Kakute or Matek boards are nice.

1 Like

Agree with @dkemxr - the Pixhawk 2.4.8 variants have always worked reliably for me, and will easily fly the latest versions of Arducopter. The following is a link to a HolyBro unit with GPS, basic power module and telemetry radios from a reliable vendor:

Looks like it is Disarmed.

I tried the instructions here to arm it, but no luck. https://ardupilot.org/copter/docs/arming_the_motors.html

How did you come up with that Mission Planner screenshot? It’s amazing I have the identical one…

1 Like

I use Snagit. Been using it for years to capture screen video and images. It’s the best.

Well. I have ordered the PixHawk 32 and an FrSky RX8R since it looks like my old receiver is not compatible.

I would still like to get the motors spinning on the APM2.8 before the new stuff arrives, so if anyone knows how to get the system out of Disarmed mode, please let me know.


If you plug an ESC directly into the radio receiver does the motor spin using your transmitter?
What ESC’s are you using?
How are you trying to arm the copter?
GCS or transmitter?
Have you set the parameters for arming (right rudder)?
When you try to arm (GCS or Tx) what do the messages say on the GCS?
They appear on the HUD but also in the Messages tab.
Have you read this page https://ardupilot.org/copter/docs/common-prearm-safety-checks.html ?

My question was really what were you taking a screen capture of. Is that supposed to be showing your craft connected to Mission Planner?

yes. that screen image is of the craft connected to mission planner.

OK, you have an RTK GPS module? Anyway, if you go to the Messages screen it might display some useful info about why it won’t arm. A screenshot of the entire screen would be more useful.