APM 2.8 Minimosd Video but no OSD information. HELP

Im using an APM 2.8 with minimosd. Im using MissionPlanner 1.3.7277.34800
When i interface with minimosd and open OSD_Config, i can successfully read my setup.
My problem is, when i plug battery into quad, i see video only, with no OSD data.

VTX - Woolfwhoop TS5828
Cam - PZ0420m
OSD - MinimOSD Rev. 1.1
FC - APM2.8

Minim TX to APM Telemetry port RX
Minim RX to APM Telemetry port TX
Minim +5V to APM Telemetry port 5v
MINIM GND to APM Telemetry port GND

MINIM VIN to Camera signal
CAM is using 12v directly from PDB
CAM is using GND directly to PDB

I tried enabling OSD in missionplanner however nothing happens
I tried adding SR params to Missionplanner parameters but still same result.
No OSD information displayed. Only video.
Please help.

Intresting… Have you connected the camera GND and VTx GND to the minim osd camera (VIN) GND and VOUT (VTx) GND respectiveley? I read something about a two stage power setup on the minim OSD, and this may be resulting in some grrounding issues if it is not connected in this way:

Try that and see if it works. I’m not entirely sure but it’s worth a shot…

Also, what is the firmware on the minimOSD? Is it the default firmware? Changing it to Minimosd-extra NG or MWOSD may fix this. But its unlikely to be a firmware issue as you mentioned that the config tool reads your APM which means it is most probably something else. Mess with the firmware ONLY as a last resort.

Have you read: https://ardupilot.org/copter/docs/common-minim-osd-quick-installation-guide.html ? Have a look.

And also, try and get a newer flight controller (pixhawk or something) your missing out on a lot :wink: Its VERY worth the upgrade!

1 Like

rough guessing here, but as you don‘t seem to see any overlay characters at all, it might be worth checking if you do have a font file uploaded properly.
power supply is a known suspect for issues too.
plus iirc on old apm boards you won‘t have mavlink output on serial port as long as your board is connected via USB.


Now that I did not know. Explains a lot! Thanks!

I packed it up waiting for a replacement. Will try again when it arrives.

1 Like

Right. Keep us posted! :wink:

Alright boyz! It works. I have OSD data on the new minim OSD. However there is a problem, battery voltage info is at 0.00 displayed. Trying to figure it out now? Advice?

1 Like

Solved, IM using the wrong power module.

Thanks fellas.

1 Like