APM 2.8 internal compass without external compass compass 1 error 99

APM 2.8 internal compass without external compass showing compass 1 error 99

The link below has details screen shots


Is the jumper installed to enable the internal compass?

I am new … I have uploaded the pics in the Google drive

Add a jumper to the pins shown here:


That’s that pin named as ?

It helped thanks. Alot

Internal mag enable I suppose. These APM’s are very old and no longer supported. It would be wise to replace it with a flight controller that will run the current firmware.

1 Like

Can you please send a pic of jumpers installed… it will help so much. I am just a beginner in this… please.

I threw away my last APM a couple months ago but there is a picture above. What else do you need?

I got it thanx… everything works fine now.

bro i got same problem can u help me…i connected jumpers but it isn’t working

i am using same 2.8 but jumpers isn’t helping…can u tell me wat u did…

hi rahul
how did u solved the issue
im facing the same error pls help

Tenho uma APM 2.8, apesar de serem antigas sĂŁo
Muito confiáveis.
No desenho, o jumper de baixo Ă© o do Compass.
Com o jumper, funcionará o compass interno.
Sem o jumper, funcionará o compass externo.
Nas APMs, nĂŁo e possĂ­vel habilitar os dois compass, como e feito na Pixhawk, onde se um falhar ou outro assume.
Espero ter ajudado.

Hey i am facing the same issue did it work for you?? Please reply i am helpless i connected the pins still it doesn’t work