APM 2.8 does not recognise gps

hi, im using a apm2.8 with ubloxm8n gps
im getting gps:no gps issue
in the status window GPS_STATUS 0
in the paramenters i have set gps type to 1 (auto).
i checked the wiring and everything is perfect,i even tried different baud rates for seial port 0 but nothing solved it.also enabled the gps and performed the compass calibration but nothing works
even the mavserial pass dosent work
NOTE:the gps turns on and when outside blue lights continuously flash indicating a gps fix and the compass in the gps module works
please help me asap

Can I see the parameter picture about the serial port?


can someone tell me what i should do
this is kinda urgent

Not many around that can help with those obsolete Flight Controllers that haven’t been supported in many years.


Im open to any kind of suggestion give me something.i think there is something im not doing right

Baudrate could be an issue.
I would check at what speed the GPS works and check the relevant settings in the APM.

Actually i tried with different baud rates the gps module connects fine with ucentre but it wont communicate with apm

Also if someone can tell me what settings should i check in ucentre and mission planner

Default parameters should work. If it’s any help I blew the dust off an old quad with an APM FC. Here is the parameter file that works.
APM V3.2.1.param (5.0 KB)

BTW-Don’t manually change the SRx parameters if you see them different than yours here.

Actually i dont have a serial x parameter all i see is serial 0 and serial 1 parameters

I will try with your parameter file and update here

The x is just a short form for saying SR0_ and SR1_

I dind’t say serial x I said SRx meaning SR0_ or SR_1 parameters.

Ok i will try these and let you know

Also this old quad has a telemetry radio so there will be parameters set for that.

Ok i have a question
Will the apm auto configure the gps ?

I don’t recall if Arducopter did at that level of firmware or not.

Ok this does not work anything i should try

Replace that Flight Controller with one that is supported.

1 Like