APM 2.8 broken Micro USB

Hi guys,

I have an APM 2.8 with broken Micro usb port, I wanted to connect it with Mission planner, how can i use an FTDI Adapter or a USB to TTL adapter to connect with mission planner just like how we connect an Arduino pro mini with Arduino ide.

connect to the telemetry port at 57600.

It’s a good time to get a supported flight controller and use the latest firmware.


Already tried that, It times out and gives me no heart beat packets received error

I already have a Pixhawk Quadcopter, just wanted to fix the apm2.8

if you take the case off there are pins for uart0 that connects the 32u to the atmega 2560, you can connect there at 115200. i cant remember if there are any other steps its been a while.

Thought I wanted to fix a Palm Pilot once too then thought, why?

Can you give me a detailed pic of the circuit connections

just google it, its well documented.

I have flown with apm 2.8 earlier, it was very good given that the board is retired, I want to make another Quad with the old components that i have.

I am not sure, I have searched so many times, I can’t seem to find any good and detailed documentation.


Yea so did I 7 years ago but I would not waste my time with an obsolete Flight Controller no longer supported today. I actually have an old quad with an APM that also has a inoperative USB port. A telemetry radio works fine except for updating firmware but of course that’s not a problem as there is no firmware to update.

You will be pretty much on your own figuring it out as there is no one left around to help. You can see this pretty much anytime a question comes up about an APM.

Here is one from today Obsolete APM


This the board i have i have soldered the uart0 pins with the ftdi adapter as follows

5v - vcc
Gnd - gnd
Tx - Rx
Rx - Tx

But when i tried to connect with the ftdi adapter, it was getting stuck on getting params

I understood dave, Its not worth the time, I may use that time for tuning my Pixhawk Quadcopter instread.

It’s worth as much time as you’re willing to put into it. You’re doing the right things. But perhaps this one is past saving.

1 Like

thats a v2.8, no idea where to solder to that as it was only v2.5 and 2.6 that i used.

That is a quite an impressive demonstration of the excellent support anyone can benefit from our community :star_struck:

The new user comes in with an outdated , broken Flight Controller and within 24 hours he receive support from 4 experienced guys , I call it a WOW!!

Thanks @geofrancis @dkemxr @xfacta @Yuri_Rage


No Problem, geofrancis appreciate the help
Anyway i have given up on the apm2.8

1 Like