APM 2.8 Bad Compass Health and RC not Calibrated

I am new to drones and need some assistance, I have an APM 2.8 flight controller while calibrating it in Mission Planner it gives an error as bad compass health and it does not show the points for calibration in live calibration mode. So, I bought a new flight controller of the same specifications it shows the same error and while calibrating RC it does not respond to the transmitter but keeps flickering on its own. I tried even installing firmware again but of no use, the transmitter is bound to the receiver.
The transmitter-receiver I am using is from flysky FS-I6b, and the copter is f450 with 1400kv Bldc motors and 10" props, and no GPS.
Thanks in advance, kindly help me with this issue.

The APM flight controller is long obsolete. I would suggest replacing it with one that will run current Arducopter.

Thanks for the reply, but can you suggest anything that can be done as I am working on it.
And I want to know the reason behind it.
Thanks and Regards.

No GPS means no external compass. Google “APM Compass Jumper” for some info about enabling the internal compass. APM’s accept individual PWM or PPM (with a jumper).

Thanks for the reply, but can you say more on APM compass jumper and what can be done for RC not calibrated, to correct or repair it.

Thanks & Regards

During compass calibration, I don’t get the points to calibrate the drone,

And during radio calibration, without me using the transmitter the green lines keep flickering,

Kindly help me with these issues.
Thanks & Regards