APD ESC and BLHeli: Connection to ESC Failed

Hello everyone,

I need some serious help!

I am trying to run DSHOT on my x4 setup and am using APD’s F series (120A) ESCs, a pixhawk for flight controller, and T-Motor motors. I have followed step by step instructions listed in the ardupilot section for using BLHeli pass through (http://ardupilot.org/copter/docs/common-dshot.html). Using the pass-through, I can’t get my ESC’s to talk! I am using BLHeliSuite32

I can connect to the flight controller no problem, but when I go in and click read setup, the message “Connection to ESC #1 failed, please check data- und power-connections to the ESC!” Note: I have tried with both a pixhawk and a pixracer, and have had a partner of mine re-check setup and wiring, same problem.

Am I missing any parameters? Could my wiring be wrong? Am I using the wrong BLHeli version? Someone has to have tried this!

I really appreciate any help I can get!

That version of BLHeliSuite works OK for me with typical settings:
SERVO_BLH_MASK to your output channel bitmask. 3840 I suppose for the Pixhawk, 15 for PixRacer.

Ahhh tried that with no luck! Out of desperation I tried to flash the esc with some new firmware listed in another rc forum (https://www.rcgroups.com/forums/showthread.php?3261041-APD-F3x-ESCs) and restarted the process, still no luck. I’ve about had it and am pretty close to finding a different ESC.

@memart as far as i can tell from the specs and sites you linked, those ESCs just do NOT run blheli_32 firmware.


Indeed. “brand new firmware developed from the ground up” wouldn’t be BLHeli.

impressive specs on those escs though…

Hmm okay that makes a lot of sense lol… oops.

So straight out of the package i’ve hooked up a single APD esc to my PDB (power cables) and pixhawk (data cables) and then to the t-motor on the other end. I disabled BLH passthrough, and changed my mot_pwm_type to dshot600 since the esc protocol calls for: Proshot 1000-3000 and Dshot 300-2400…

I have read that it is not necessary to calibrate the ESC’s since they use Dshot…
I was able to do a motor test and on motor A and the motor fired! I tried with my RC controller and it fired as well so that is a good sign.

But do I need to set anything up or am I stuck with whatever configurations the ESC came with (at least when i’m using the Pixhawk)?

And i’m guessing there is no way to do an x8 config using these ESC’s and a pixhawk since there are only 6 aux ports. I was hoping I could use the main out pins instead and be able to swap between a x4 and x8 config. Wouldn’t it be nice

Hey, where did you land with this project?