APD Dshot ESCs not syncing properly


I am running a quad setup with APD’s F3 120A ESC’s. I just switched to a mRo control zero flight controller.

I am having weird syncing problems with the ESC.

I can plug in any one of the ESCs into the control zero at a time and that one becomes synced. Individual motor tests work.

I can plug any three ESCs into the control zero at the same time and all three become synced. Individual and combined motor tests work. Any combination of the three out of four works, it’s not just one single ESC.

Once i plug all four into the control zero, none of them become synced and so the motor test does not work. After a couple of minutes, of sitting there, some of the ESCs start making different beeps and sometimes a random motor plugged in will spin or twitch. That is pretty disconcerting.

It doesn’t sound like an ESC issue, it sounds more like a flight controller or a signal issue.

Does anyone else have this problem and have a fix or suggestions on routes to take?

For reference:
If the ESC is synced, after the startup tone it makes one beep every 10 or so seconds
If the ESC is not synced, after the startup tone it makes one beep every 5 seconds or so.

Sort of solved the issue.

I tried with a Pixhawk which had an OCTA frame class set up on it. The ESC’s all synced and I was able to fire the motor tests. Changed the Control Zero to an OCTA frame class and whaddaya know they synced…

But I came up across another problem… for the quad setup, the motor test is weird…

Motor A -> front right
Motor B -> front left
Motor C -> nothing
Motor D -> back right
Motor E -> back left

Will have to change some of the parameters… will update!