Servers by jDrones

AP not connecting to APM 2.8 board on OSX Mojave


(Neil) #1

So I’ve been reading and trying things over and over now for about a week. really starting to consider throwing the drone and everything in the trash but don’t want to be out a few hundred bucks!!!

So here is my issue:
i have the latest version of AP (apm_planner_2.0.27-rc1_osx.dmg) but when i connect the board to my MAC, it wont connect. I’m using FTDI usb serial but it wont give me a com port to use. my only options are Bluetooth or iPhone and neither of those work.
now, as i said before, I’ve been trying to do research on this for about the last week and i havent found one single person that has come up with a solution. and before you ask, i have uninstalled and reinstalled everything about a dozen times so far and I’m almost at the end of my rope.

PS, I don’t know about programming or coding and all of this is new to me and i have absolutely no access to a PC before you try to give me those options.


(Hari .P) #2

http://ardupilot.org/copter/docs/initial-setup.html


(Sebastian Schürmann) #3

What do you use the FTDI Adapter for?


(Neil) #4

The FTDI is a usb to serial adapter so that my MAC can connect with the FC. it’s a software adapter.


(Mike Boland) #5

You’re going to have to elaborate on what exactly you are connecting to what.
I run Mojave 10.14.4, use APM Planner, and connect with everything from APM2.6, Pixhawk 1, the Cube, Pixracer, PixFalcon, to name a few.

I use a USB only and it is USB to micro USB.

Please explain the need for an FTDI cable as previously asked.
You may need to include pics.


(Neil) #6

I run the same version of Mojave and I have the APM 2.8. I tried running APM Planner but when I plug it in with the usb, it doesn’t show the device anywhere. FTDI is the software I was instructed to use for usb to serial so that the APM 2.8 can be found by the computer. I also use a usb to micro usb cord. FTDI is just a driver, not a physical cable.


(Neil) #7


(Mike Boland) #8

First question : is the Mac seeing the device?

Next: this is the link that I followed for the driver installation
And all has worked after that.
There is an installation document here for OSX that I needed to follow some time back to sort out comms problems. Since then there hasn’t been an issue.


(Neil) #9

Thank you. Found out what was going wrong. It was something dumb. Usb cable was bad.

But again, thank you for all the help!! I’ll probably be back again with more questions about something else soon