Servers by jDrones

Antenna Tracker with PT785-S Pan & Tilt System (3.8:1)

Despite the very few examples of APM antenna trackers being used for FPV in the field I am going to make one with the Servo City PT785 (3.8:1). Has anyone else used this?

I will try to document and report back with how I am doing. If anyone else has used this admittedly rather pricey unit from Servo City please let me know how you did. After using a MFD with sloppy chattery servos I just decided to get a better unit with more torque. It looks fabulous. Let’s hope it performs well.

Also, APM AAT does not support continuous 360 yet does it? That would seem to be a good idea.

It would be nice to see more action around Antenna tracker and OSD areas of Ardupilot.

Any word on this? Just received one, pixhawk isn’t driving any of the servos in testing. Was hoping you’d have some insight.

Chad. I have this unit working as a Pitlab AAT right now. I plan to fire up an Ardupilot AAT with the same thing and make it dual use. Not done it yet. I hope I can document some success or lack thereof soon. Sorry I cannot be of more help now.

Did you guys ever finished this?

I have the same problem that Pixhawk is not driving any servos in testing. Pls see my posting under " Testing button not working in Antenna Tracker Extended tuning page".

But when I use APM 2.6 as AT controller, it drives the servos in testing. Weird.

Any news on this issue ?

Posting on this thread because I’m building an AT with the PT785-S pan/tilt set up as well. I’m using a pixracer as the control board. After having a few issues with the set up process and getting through that, now I’m having difficulty tuning the system with the multi-rotation servos on the PT785 (HS-785HB servos). The system will yaw and pitch no problem with the test button in the extended-tuning page, but I cannot send PWM signals <1100 or >1900 so there’s no way to test the multi-rotation. It also doesn’t rotate a full 360º, just about 330º. When the tracker is in Auto mode it will yaw fine until it reaches the end of its first rotation, then it just gets stuck there shaking back and forth, it never reverses back around the other way at all. When this happens it pitches over past 90º (despite the limit I have set in the tuning page) and points at the drone upside down.

I think it’s an issue with the way the servos respond to the PWM output of the pixracer but I don’t know enough about any of this to work out how to fix it. I’ve tried tuning the PID values and this reduces the amount of shake but doesn’t send the yaw back in the other direction, nor continue around past about 330º.

I’m hoping someone out there has been successful with the PT785-S and can help me out, especially as it’s one of the systems suggested on the antenna tracker page.



Ok so I went in and used the Servo Output page to manually enter the min, max and trim values. I got min and max from the servo spec sheet (600 - 2400) then I used the extended tuning ‘test’ button to find the trim value. Doing this now allows the yaw to turn almost 2 full turns using the test button, and it also does this in Auto mode. Doing the same with the pitch servo stopped it from over pitching beyond 90º. This might be obvious to experienced users, but it wasn’t something covered in the AntennaTracker Documentation page.

But… there is still a very strange yaw oscillation that happens when the tracker starts tracking a moving target. It begins moving OK but then will get into a position where it is facing 90º to the target and it just sits there yawing back and forth. I can reduce the amount of yaw with PID tuning, but still can’t seem to get it to move properly to point at the target.

Progress, but still not right!

Ok, following up on previous posts. I got the tracker to function correctly, not quite tuned 100% but that’s easy enough from here. The things I did (additional to what I already described):

  • the yaw servo had to be set as ‘continuous’ even though it is not a continuous rotation servo. I have no idea why that worked, but it did.
  • the pitch servo had to be set as ‘position’, which is the correct setting for this type of servo.

Once I have the tune sorted out I will post my param file for anyone else using this pan/tilt mechanism. It’s been a frustrating journey, but I now have a working tracker.

Servers by jDrones