Servers by jDrones

Antenna Tracker Troubleshooting Help

Hello all,

Good morning. I need some help troubleshooting my antenna tracker build. I’m currently running the following:


  • Mission Planner 1.3.68 Build 1.3.7105.26478
  • Antenna Tracker AT 0.7.5 - AT 1.0.0


  • 1 RFD 900x
  • 1 Pixhawk 2 Assembly ( Buzzer, Arming Switch, Power Cable…)
  • 1 Servo City HS-785-HB Servo Set

Set - Up / Issue:

  • I have an antenna tracker set-up based on the instructions from
  • The servo’s pan and tilt in the correct directions.
  • Servo’s are not continuous servo’s, but are multiple rotational servo’s. Max range for both servo’s is about 349 degrees.
  • The accelerometer calibration was completed and successful.
  • Compass was calibrated on the antenna tracker ( also successful and reports true).
  • Arming button / buzzer works as expected.
  • When my copter is powered on, I can see my copter on mission planner next to my antenna tracker. I can see the orange line tracking it as well.
  • If I’m running AT 0.7.5, the antenna tracker with follow my copter, but will not follow it in the tilt. If I exceed the pan in the right / left direction, it will pan all the way back around to the left / right to try to regain communications. I’d assume the tracker would take the shorter route. The orange tracking line locks on straight away, and when I put it in Auto mode, it instantly tracks my Copter.
  • If I re-flash the Pixhawk 2 with AT 1.0.0, the antenna tracker will not longer tracker my copter. The orange tracking line intersects the copter, but the red line will not lock on. In Auto / Scan mode, it will pan and tilt at the same time to look for the copter, but it will never lock on.
  • I verified that the copter is outside of it’s distance limits, and concludes with the same results.
  • I have even attempted using a Pixhawk 1, as well as a Pixhawk 2 Cube, with similar results.


  • Does anyone know why that upgrade in firmware would cause it to not track ( pan / or tilt ) wise?
  • Has anyone experienced any of the same results and could help offer any assistance?
  • Is there possibilities for incorrect installations or processes?
  • What could I possibly be doing wrong with my set-up that others have had success on?

Any help would be greatly appreciated. This has been an ongoing project for a little over a year, I’d love to get this system up and working. Have a wonderful day.

@adam_kelly @rmackay9 @tridge @ChrisOlson


Hi Todd,
I’m certainly no expert, but I had similar issues with the same servos. What worked for me (in terms of getting the servos moving correctly) was:

After a few other issues and some “change it and see” PID tuning mine now works well, I hope you have similar success.



Hello Adam,

Good evening. I have read your comments on your previous forum with not much success. Would you be able to share your .parameter or even your PID tunes? When I change the mode to “Servo Test,” I can move the pitch just fine. Even when I select the mode into “Scan,” it pans and tilts to their minimum and maximum pulse width modulations; however, when I go in “Auto,” it will lock on with the pan axis but will not tilt (that’s using AT 0.7.5). Using AT 1.0.0, it doesn’t do any of that. Why would the pitch work in other modes and not in “Auto”? After changing your servo’s to position and continuous, did your antenna tracker actual heading line and tracking line parallel?

Hi Todd,
yes that’s pretty much how I was experiencing it also. Everything worked as you’d expect when I was using the test buttons, even with a plugged in joystick, but it wouldn’t track at all in Auto mode. The changes to the servo types made the biggest difference. I have no idea why!

I’ll get a param file for you, not sure how much it will help but it can’t hurt. My tracker runs on a pixracer, RFD900+ and an MRO GPS/Compass module. [edit] Oh my board alignment is very strange as well, so you’ll definitely want to change that before you use the file.PZ Antenna Tracker 13Nov.param (8.4 KB)


I’m playing with a PT785-S with HS-785HB servos here.

Very, very rough stuff ATM, really just hacking parameters until it works, which it kind of is ATM. I have some suspicions that some of the PID parameters were zero where they really shouldn’t have been.

It would be nice to get a parameter file in ArduPilot’s Frame_params directory for this tracker.

My very rough parameter set, as yet untrimmed to take out default values:
pt785-s.parm (13.5 KB)

Hello @Adam_Kelly @rmackay9 @Michael_Oborne @proficnc

Thank you very much for your parameters. I’m able to have my antenna tracker pitch in auto mode. I’m having two issues. When it locks to my rover, it doesn’t point true in the pitch axis. The yaw axis points true; however, the pitch axis seems to point about 10 degree’s higher than my rover, regardless of my rover height. It also tracks extremely slow in the yaw axis. Has anyone been able to move parameters around to help track there plane or rover faster? I could really use the help.

Try playing around with your PIDs, just make small changes and see if it improves.

Has anyone been able to solve this yet? I’m having the same issues. I have been trying to get this damn thing to work right for weeks now. All seems well in setup, but when its in Auto, it seems like its in scan mode. Ive tried playing with PID, servo type, and tried the parameters above that others have gave.

I’m using an HS 785HB for the yaw servo. Just ordered a digital continuous rotation servo, as that is the only possible thing I can think of that is the issue. The HS785 is continuous rotation, but its geared really low and drives my yaw movement directly. When you do the math, my 8-bit rate would be 56, which isn’t even possible.

Servers by jDrones