Antenna Tracker - Step By Step Setup and Simulator

Thanks for the competent and quick explanations.
I will update the diagram and I’m motivated to order a Pix to try it a third time. :wave:

Edit: For the Params Serial_Protocol Mavlink1 or Mavlink2 ?

Doesn’t really matter, although I think the general consensus is that if possible you should use mavlink2 on everything, the only reason the default has not been changed to this is that some older telemetry radios only support mavlink1

The GPS module does have a compass in it, but I did not connect it to the tracker (Pixhack) as it causes a lot of trouble such as COMPASS VARIANCE. SO I only use the built in compass in Pixhack, as you can see from the param which I attached…values shown only under mx. my and mz, but zero for mx2, my2 and mz2.

I use alway the external (GPS) Compass because it is far away from electrical wires. This is more important in a vehicel like copter with high current consumption. But then, I deselect the internal Compasses (2) for the mentionned reason. (MissionPlanner/Initial Setup/Compass

I would try it anyway, regardless of whether or not the compass is connected. I thought the same thing when I was trying to get my pitch to work. I kept telling myself that it cant be the problem because I pulled the compass/i2C wires out from the harness. I spent over a week going crazy trying to figure out what was wrong. When I finally did move it to the pitch carriage, and connected the compass, it started working correctly. I think there are some bugs in the AT firmware that prevent it from allowing us to disable or configure compass parameters other than what it expects to see.

Give me a few minutes and I’ll pull my parameter file and share it here.

Yes, 0° for pitch is level with horizon.

When using the servo test function, I don’t believe the range settings or servo reverse settings are used.

Here is my parameter file.AT Param 12-28-19 Mackinnon.param (8.3 KB)


1 Like

I’ve been fighting trying to get this to work for a long time. I had the GPS mounted to the antenna tracker frame and had not connected the the GPS mag. Was only using the internal mag on the pixhawk. After reading some of the latest posts I connected the mag from the GPS and mounted the GPS to the pitch axis and disabled the internal mags on the pixhawk. Guess what, it worked, makes no sense to me. It’s snowing here right now so we sent one of the rovers out on a mission and it tracked it pretty well. Previously the tracker would point everywhere but where the rover was and pitch never seemed to get it right.

Thanks Ian

1 Like

@Shotfire, @Itmac79
What is your setup?
As recommended bei @iampete and my diagram in post 17?

Yes it is the same as the diagram. What servos are you using?

I tried twice with the mechanic of a old Tracker from a analog Video System where the electronic was defective.
The Yaw Servo is continues, the pitch Servo standard 90°. My system did not work, the Yaw Servo turned all the way until I disconnected the Battery. Now I will order a new Pix and try again with the recommended setup.

Just found another mechanics in my shelf.
This here is good and cheap:
All you need according manual: Philips Head Screwdriver, 7/64" Hex Head Driver, Hammer :wink:

Hi Ian,

I took the tracker out to the field yesterday, with the GPS module stacked on top of the tracker (Pixhack). When I powered on the tracker and pressed the safety button, the antenna flipped back from -10 deg to +110 deg (roughly), throwing the dipole antenna off the telemetry radio, so testing has to stop. At that time, the quadcopter was on the ground, 8-9 meters away from the tracker, which was mounted 5 feet high on a tripod.

This is an improvement from last time, as the antenna did not pitch at all.

This issue has puzzled me for long time :-

What param in MP should I set to make sure the tracker won’t go crazy as soon as it is live ? The nearest param are START_LATITUDE and START_LONGITUDE. But when the GPS is locked, will the tracker point at my quad, which in on the ground in my case ?

Also for the pitch servo, I just engage the pitch servo disc to the servo spline corresponding to a random antenna pitch position. I think it is not a correct way.

Wiki does not answer these questions. Can you share your experience ?

Thank you.

Send me the parameters you used today and I will take a look. You may have to adjust the pan/pitch speed. I’ll take a look and compare to what I have.

I’ll try to put together a step by step for setting up the pitch servos tonight.

Thanks for your support. Attached is the param I used to test at the field.

Appreciate your help.

Tracker param__30 Dec 2019.param (8.41 KB)

Here are my suggestions changes based on your parameters…I highly suggest that you test it out on the simulator before you try it out on the field. It’s so much easier to make adjustments and get it fine tuned. There is a step by step description on how to do this above.

Re-calibrate your Compass’ again in their current mounted location that move with the pitch axis. Confirm that your board orientation is correct and that the horizon and compass values shown on the HUD on the Flight Data screen are correct and moving in the right direction.

Change pitch servo type to continuous rotation - even if its not. For some reason the code for position servos has issues. Others have had success after changing this to continuous rotation when using position servos. I still highly recommend investing in a high quality, digital continuous rotation servo if you are not already using one for pitch. It makes tuning 100x easier.

RC2_MAX - 1700 - your current setting is 1900. Start with a lower value and adjust it after you get it working properly to fine tune your max values to your physical endpoints.

RC2_MIN - 1400 - your current setting is is 1100. Ideally you want this to be your servo’s midpoint value, or just a bit lower.

PITCH_MAX 85 - your current is 90, but for tuning, its better to leave some room for fine adjustments.

PITCH_MIN 0 - you currently have it set to -60. I think this is the primary issue causing it to violently pitch when you turn it on. It thinks it has 150 degrees of travel.

PITCH_SLEW_TIME 2 - your current setting is 10. This controls how fast the pitch servo moves.

DISTANCE_MIN 4 - You have it set at 6 currently, but it might help to lower this.

Please don’t do this, use whatever servo type you have fitted.

I suspect this is your real issue, @peterbarker recently found a bug in this param. It is inverted in the code in one place, this means your -60 limit was actually +60. So try putting in +60 to get -60.

Hopefully we can do a new release with this fix soon.

Thank you for your
review on my setting. I have changed the parameters according to your
recommendation and will try out next time, most probably not this
weekend, as weather is not permitting.

On simulation, I
simulate using SITL with limited success. First, I was not successful
installing Cygwin. But I managed to launch SITL by following steps as

and issue FLY TO HERE command, the tracker follows the simulated quad
ONLY in yaw, but not all the way. It stops yawing sometime later,
though the quad is still moving.

The yaw servo has been
modified to rotate 360 deg. And the tracker NEVER pitches, though I
increase the altitude to the maximum allowable in the ACTION tab
under HUD in Mission Planner. Not sure if the performance is due to
lack of Cygwin. All these happen few days ago, before I changed to
your recommended setting.

3 questions : –

  1. On altitude
    source, do you use BAROMETER in MP ?
  1. As for the pitch
    servo, I use Tower Pro MG996R digital servo, and have already
    modified it to rotate 180 deg by adding 2 resistors. For
    experimentation and testing the tracker, I do not intend to fly the
    quad behind me, so I think 180 deg is sufficient. What do you think

  2. Based on the
    diagram as attached , pls confirm net ID of the radio connected to
    the antenna should be the same as that of the radio airborne.

    I just found out
    today, all I have been doing is the airborne radio ID is same as
    that of THE OTHER radio connected to ANOTHER telem port of the
    tracker. i.e I have 2 radio connected to the tracker, one for the
    directional Yagi, the other for the radio with normal dipole. But it
    just works, at least it yaws. Pls comment.

Today, when I tested
again out in the field (after moving the GPS to pitch with the
tracker), the tracker did not tilt. But what was doing right before
became wrong today…when I picked up the quad to move across the
tracker, the tracker yaw in opposition direction to the moving of the
quad. I tried few times, and it happens every time.The param are what
I sent you before. It is weird. Any clue ?

Thank you for your continued help.

In case you cannot open the "Antenna connection to tracker " file, here is the link :--

(Attachment Antenna connection to tracker.odt is missing)

(Attachment SITL.docx is missing)