Analyzing an Autotune Log

My quad is built around a Pixhawk 1 with Arducopter v4.4.1
I wanted to run Autotune so I assigned the switched Aux channel on my remote to toggle between the following settings: Autotune / Althold.
I took off with my quad and moved the switch to Autotune, I had to land after around 10 minutes due to some thrust loss.
After landing I connected my PC to the board via a USB cable and downloaded the .bin log file (attached).

I tried to review it myself in Mission Planner but can’t make sense of all the data.
Please help me analyze the log.

1.What data points on the right hand side of the graph viewer are the most relevant for analyzing Autotune ?
2.Did my GPS and all other sensors work fine ? What data points show that ?
4.How can I tell whether the Autotune process completed successfully and the new PIDs have been saved ?

1 Like

It was premature to run Auto Tune on this craft. The outputs are oscillating wildly and you haven’t configured the Notch filter.

See all those massages at the bottom of the log graph here? The say “Autotune: failing to level please tune manually”. This is as bad as it gets.

Forget about Auto Tune until this craft can basically fly. Decrease the Rate Pitch and Roll PID’s by half. And follow this to set the motor ranges Setting Motor ranges
Set these:

And make a simple hover flight in AltHold for ~1 min.


Thanks for your input.
That’s very interesting - to the naked eye it looked like it flew quite stable.

What parameters did you enable in the graph to see the screen that you pasted ?

Sorry, I cut of the graph ranges. Fixed. Auto Tune didn’t run at all, still on Default PID’s (which is the problem).

Thanks. I’ll tune the settings you recommended and post another log.

Your battery was down to ~2.9V/cell. If it’s a Lipo you will damage it discharging it that far. That’s why there were thrust loss messages.
And you really had an insufficient number of Sats and a high Hdop before taking off.

And there is a banner message saying that it is a 1Mb Pixhawk board and should be running the Pixhawk1-1M firmware.
You are batting 1000! :slight_smile:


I was wondering what’s that annoying message coming from Mission Planner as soon as I connect.
Should I recalibrate my sensors (accel/mag/etc…) after fixing that ?

Yes I would. And I would run Magfit to calibrate the compass. Magfit
This should be routine for every new build.

I meant after fixing the version problem (I already ran the Accel/Mag/etc… calibration prior).

Right. But I’m saying run Magfit after the standard compass calibration.

Got it. But what about the accelerometers and the basic compass calibration ? Is it required to redo it after the firmware change ?

Generally no when updating firmware but that’s not what you are doing. Just re-do them

1 Like

I had another short flight after configuring the accelerometers, compass, motor ranges and these values:

Here is the log:

I haven’t modified the PID’s yet (that’s for the next flight later today)
Can you please specify which PID parameters exactly do I need to “decrease by half”

The Rate PID’s and you won’t be changing them on that screen. Use the Full Parameter list.
These and the same for Roll (RLL)

1 Like


BTW, can this poor performance also be attributed to vibrations to the FC ?

They can contribute to poor tuning but the output oscillation is generally something else as suggested. In any case your Vibe levels are in an acceptable range.

Post another log after the PID’s have been lowered. You can’t configure the Notch filter with the output oscillation you have.

Here’s the log from the last flight:

During this flight the Quad was very hard to control - at the end I had to crash land in the grass.

You didn’t change the rate Roll values. Try setting these:

Also, your battery is sagging badly right from the start.

1 Like

The following parameters are already at these values (these are the defaults):

And I guess I need a new battery…

Sorry, i meant to edit them to be the same as Pitch.

1 Like