Servers by jDrones

An Open Source Frsky Telemetry Script for the Horus X10,X12 and Taranis X9D,X9E and QX7 radios

frsky
ardupilot
lua

(Alex Apostoli) #221

It’s the single cell battery voltage reported by the flightcontroller as read by the power module on board. Full lipo around 4.2 down to 3.5 on landing, so it’s working :slight_smile:

EDIT: To be more precise, it’s the total battery voltage reported by the flightcontroller divided by the cell count detected by the script. On a 3s lipo pack max voltage is 4.2*3=12.6, flightcontroller reports 12.6 via telemetry, script detects it’s a 3s and displays 12.6/3 = 4.20 on screen.

Alex


(Bruce Dykstra) #222

Hi Alex,
Thank you very much for your “Yaapu Telemetry Script”.
It is very elegant and practical with the on screen information given.
I do however, have a bit of a problem.
I have a Quad Plane and when yaapu script is started, everything is as it should be and works well.

When I try to arm the Plane, the screen still shows “Disarmed” and the screen freezes (values don’t change).
After about 10 second a voice alert says “Sensor Lost” and that is where it stays.

When I disarm the plane, the screen comes back to life with the “Disarmed” icon still flashing
and it is all back to the way it should be.

When it comes back to normal, there are 2 alert beeps and the Alert Screen says
"19 DBG Throttle Armed and 20 DBG Throttle disarmed" straight after it comes back.

It seems that when you try to “Arm” the model, the script can’t find what it is looking for (Frame Type maybe)
and just sits there lost and waiting for some sort of input. The script still appears to be running.

I hope that I have explained it well enough.
If you need anymore info, ask away.

Below is a List of my setup

Horus X10
Mission Planner 1.3.56
Ardu Plane v3.8.5
Q_Enable = 1
Q_Frame_Class = 1 = Quad
Q_Frame_Type = 1 = X

I also found that the Serial Inverter (Some Soldering Required) gets extremely hot when first powered up.
I found that if you disconnect the battery and then reconnect 5 seconds later, it will run cool.
Something not quite right there. Might have a look at it when I get time or just leave it as it is
now that I know.

Regards
Bruce


(Alex Apostoli) #223

When I try to arm the Plane, the screen still shows “Disarmed” and the screen freezes (values don’t change).
After about 10 second a voice alert says “Sensor Lost” and that is where it stays.

When I disarm the plane, the screen comes back to life with the “Disarmed” icon still flashing
and it is all back to the way it should be.

You probably have a problem with logging on your sd card. Writing on sd starts as soon as you arm.

telemetry is freezing on your vehicle not on the radio

cheers

Alex


(Corrado Steri) #224

Ok, great to know!!

Thanks


(Bruce Dykstra) #225

Hi Alex,
You were spot on.Replaced the card with a class 10 and it worked straight away.
The weather has not been to kind here and haven’t had a chance to fly it yet so I would like to ask, when does the “Armed” icon disappear to reveal the Home Direction?

Thanks again. I would never have thought of looking at the SD card as the problem.

Regards
Bruce


(Alex Apostoli) #226

Hi Bruce, the armed warning should clear as soon as the flight timer starts.
arm and start the motors ant it should clear.


(Bruce Dykstra) #227

That is what I thought.
The Flight Timer on my setup is not counting and therefore the warning does not disappear.
I had a look at the configs but can’t see any timer mentioned.
Do i have to set it up on the X10 or in Arduplane.
Bruce


(Bruce Dykstra) #228

Just found something interesting.
The X10 will discover all the sensors in the sensors list which have to be typed in.
You select “Discover Sensors” but don’t turn it off. Start the “Yaapu Script” then when you go back to the Telemetry screen, you will find them all there. Then turn off discovery. I checked all of them against the list and found the “A2” was the only one that didn’t match up with the list.

Bruce


(Alex Apostoli) #229

Thanks Bruce, good catch, I’ll add it to the documentation 'cause it’s a much simpler way of doing it.

As for the Arm/disarm window that’s strange.
On a quad as soon as you arm and raise throttle ardupilot sets the “vehicle is flying” status right away and the script starts the timer.
just to be clear, did you arm and give gas or just arm?


(Alex Apostoli) #230

By looking at @hurzburg telemetry logs we found out that with EKF disabled the current telemetry library does not send vspeed info, this is an ardupilot issue.

While we wait for the ardupilot team to fix it I’ve added a “synthetic vspeed” calculated by the altitude variance, it has to be enabled in the menu to be used.
It will be available in the next release.

@hurzburg did you open the issue or should I do it, if it’s open could you link it here, thanks


(Bruce Dykstra) #231

Came across it by accident.
Wondered where all the sensors came from then realized I forgot to stop discovery.

Yes the plane was armed and the window shows armed.
When the throttle is raised the motor runs but not the timer.
I let it run for at least a minute and a half but still no counter.


(Bruce Dykstra) #232

Just thought of something when you mentioned a copter. I have not tried the quad side of it yet.
The motor I am talking about is the plane drive motor not the quad motors.
Maybe the two are handled differently.
Bruce


(Bruce Dykstra) #233

Just found out what is causing the counter problem.
It won’t work while it is any of the plane modes (Manual or FBWA flight modes).
When QStabilize or QHover is selected the counter and armed warning both work.
If you go back to manual (or transition) mode it still works.
Not a problem at all when you think about it after all it is a Quad Plane.
Bruce


(Alex Apostoli) #234

that makes sense, thanks for reporting back your findings.

Alex


(Henry Wurzburg) #235

opened issue on Github : https://github.com/ArduPilot/ardupilot/issues/8484


(Alex Apostoli) #236

While looking at @hurzburg logs I noticed another small issue.
The default capacity parameter of the second battery monitor is set to 3300

image

This gets sent by the frsky telemetry library as second battery capacity > 0 which the script sums to the first battery to calculate total capacity and generates on offset in “fuel” vocal alerts.

So if battery % vocal alerts are acting weird please check that parameter value and set it back to 0!

Alex


(Alex Apostoli) #237

Hi all,
new release for the Taranis radios:

  • rangefinder support with max range from config menu
  • “synthetic vspeed” calculated from altitude changes with menu option to enable/disable (needs testing)
  • new X9 layout with bigger fonts
  • new QX7 layout
  • many small fixes

immagine

immagine

things have been moved around so for an explanation of what’s displayed on screen please check the documentation on github

thanks to all who contributed


(Henry Wurzburg) #238

Alex, everything working well! thanks!..one input however…the synthetic vertical speed/ vario is wildly fluctuating…
even in my OSD setup config program, there is an option to filter the Mavlink vertical speed by a 30 or 100 sample running average…I usually use the 100 sample option, even then, it bounces a good deal from update to update but is useable…
perhaps putting a menu configurable running average on the vertical speed (even if provided by telem) would be worthwhile…ie set the number of samples for a running average of the speed before its displayed numerically or on vario?maybe 1 to 100?


(Alex Apostoli) #239

I increased the sample period to 750ms and on my setup is usable, before it was fluctuating a lot. I updated the code on GitHub, if you have a chance try this new setting.

Alex


(Henry Wurzburg) #240

Helps! thanks…I increased it a bit more to 1 sec, more to my taste…
also, I modified the 9D script for imperial units (feet/mph/feet per sec)

thanks again!