An Open Source Frsky Telemetry Script for the Horus X10,X12 and Taranis X9D,X9E and QX7 radios

I really have no clues.
Only difference I can think of is I’m using an Horux X10 vs using the Taranis X9D+ and perhaps
I might have a more recent R9 TX (newer HW) than yours?

I tried both with you’re very same R9 firmware version and with the previous one using flex 100mW with s.port telemetry enabled and on the bench I never lost the telemetry link.

As Chris said…beats me :slight_smile:

If you have an external FrSky sensor maybe try to see if you can get telemetry without the ArduPilot converter cable hooked up. Or, if you don’t have an external sensor maybe try setting the serial port to FrSky S.Port and see if you can discover the repurposed sensors.

As far as I know, the only difference between the flex and non-flex is that the flex will show the option in your transmitter (opentx 2.2.3 only) to set the frequency. The non-flex will not show that option in your transmitter. Having the flex in your module (only with OpenTx 2.2.3) should work with non-flex in the receiver if you select the right frequency. I only put the flex in my module and Tx a couple weeks ago when I bought my third R9 receiver. My guess is, if you can’t get regular S.Port to work, you have a mismatch between OpenTx and the module/receiver firmware versions.

Your transmitter must be a X9D+ (you said R9D+). But it all works on my X9D+ here as long as I use the adaptive power setting. Has very good range too - probably double what the X8R had. The only issue I’ve noted is occasional battery voltage dropout, and sometimes “Bad GPS Health” even though the GPS is working fine.

@ChrisOlson, @yaapu as you both said: …beats me too… :wink:

@ChrisOlson I tried your suggestions with no success. Then out of desperation, I started on my silly things list.

I was using Telem2 port on Pixhawk Cube and changed it to Telem1 (also tried with GPS2 port) and it worked :star_struck: with both FLEX and NON-FLEX firmwares on R9M, R9MM and R9Slim+ setups.

So the result is everything works well in all combiations for Serial Ports other than Telem2 on Pixhawk Cube, for R9 setups. Also, for X8R Telem2 works too.

I would think that there might be a bug in ArduPlane v3.9.8 firmware for “Serial2 = 10” option, but I cant since X8R is working, so I cannot blame voltage levels or board defects.

Funny thing… :joy:

What? That is very strange. I’m using CUAV V3x on Serial 4. Have never tried any other serial ports. What causes it to work with a X8R but not with a R9 using the identical protocol is a bigger “Beats Me” than whatever it is FrSky is doing with different R9 firmwares :astonished:

I have tried your solution but nothing is working for me. I give up because it is a VTOL which I had hovering but nothing more… I started a year ago on that thing but always put it a side.
The cable I use has worked with the Helicopters FrSky Telemetry Script. Cable is ok. I am wasting no more time because I don,t like to work on planes to much. Nothing is better than a good flying Heli.

@yak-54 Colin I updated the scheduler code, now messages and attitude are handled a bit faster.
If you want to git it a try here’s the binary for the CubeBlack

yep will do tomorrow to cold in the shed its only 3 degrees out side

all looks good put the firmware on and did a logic dump (31.1 KB)

1 Like

I’ve got this minor issue. Teensy 3.2s doing mavlink to FrSky, configured to get pack cappacity from FC, but the value is still zero after a couple of flights.

you can ask for help in the mavlinkToPassthru thread Eric is very responsive!

Hey Alex :slight_smile:

I’m about to upgrade my GPS to a ZED-F9P. I think it counts L1/L2 signals from the same source sattelite as multiple sources, as I achieved 42 locked “sattelites” in the ground test.
Can that satcount byte be upgraded ? 'cause 15+ may be OK for a run-of-the-mill M8N, but the ZEDs can achive something else :smiley:

sat count is encoded as 4 bits, that’s a hardcoded limit in the ardupilot passthrough library, really nothing I can do from my side, sorry :frowning:

1 Like

Hi Alex,

I bought a new Horus 10 and have both the script v1.7.4 running and the Widget 1.8.0-beta3 running. The script feels much like what I am used to on my Taranis X9D+. What are the advantages or disadvantages of running the widget version? I can see that the Horus will boot right into the Yaapu widget, which is one nice feature.

The color display and your choices for colors are awesome!


1 Like

Hi Greg,
I no longer support the script version so the biggest advantage is that the widget has all the latest features :grin:

  • bigger smoother glass cockpit/hud
  • vocal support for many text messages
  • support for up to 6 user selected frsky sensors
  • support for the mavlinkToPassthru latest firmware with airspeed, waypoints and throttle telemetry info
  • status text messages summary at bottom of screen
  • telemetry summary in status text screen
  • independent dual batteries with cellcount override for 1st and 2nd battery (select “other” in batt config menu)
  • batteries with voltage higer than 51.1V (requires to select 12s override in config menu)
  • chained FLVSS as series wiring battery config (select “ser” in batt config menu)
  • fix to skip flight mode vocal announcement for very quick flight mode changes, like flipping a switch from pos 1 to pos 3
  • haptic feedback on warning events
  • more options to silence the incoming message beep
  • support for PX4 flight modes when used with Eric’s mavlinkToPassthru firmware (has to enabled from the config menu)
  • new menu option to define a channel to toggle between main screen and message history (by flipping a switch perhaps). This way the only mandatory page is the main page, dedicating a telemetry page to message history is no longer required.
  • support for boat frametype

latest version is 1.8.0-RC2


By using the latest widget the best approach IMO is to use 2 fullscreen telemetry pages, one for the main screen and one for the min/max screens. To access the status text message list use the channel option from the config menu.

1 Like

Thank you! You just answered my next question. :grinning:


1 Like

My switch setup is SA on channel 6. It switches between the main telemetry HUD and the Messages text screen. When setting the screens up under the widgets, I don’t see a widget for the Config Menu, only the main Yaapu page, text screen, gauge, timer, etc. Am I missing a Menu widget? The SD folder only has the main.lua and main.luac files.

Hi Greg,
you launch the menu as you launched the old script, by long presssing [SYS] and browsing the SD folder to the /SCRIPTS/YAAPU/menu.lua file

there’s also a page in the wiki that explains it

Ok, that’s what I did to start the Config Menu. Once I exit it back to the main Temlemetry HUD, the channel 6 switch shows the Messages text screen, not the Config Menu.

Should I have 1 or 2 Widget windows set up?

yes, that’s correct, the channel option can only toggle between main screen and message screen.
In widget mode button events are not passed to running widgets so there’s no way in that mode to interact with a menu, the only way to have button events is by starting the script as a one time script with a [SYS] long press.