An immediate crash with rolling over side or over the nose in alt hold


I am trying to bring up a brand new vehicle i have built - and have no luck at all making it work with 3.6.

With 3.5.5 in alt hold it has severe oscillations but still, somewhat capable to lift off and stay afloat, it is somewhat normal until autotune is done and all pids sorted out. FC is pixracer, uses 3 compasses.

on 3.6 i noted in the pids settings window in MP software several sections are simply greyed out - i guess they are depricated? PIDs that are in section that still there do not seem to have much relevance.

what i got so far is the vertical liftoff in alt hold with almost immediate flip to one of sides or nose as if it is unable to adjust. it was on chibiOS version of 3.6 i hoped to use so much, not sure what to think yet, if it is a hardware issue or code issue.

Here is a link to a log, if anybody could say why it happened i would greatly appreciate it.

can’t get to log from work, but first question is, are you using latest MP that is updated for 3.6?

MP was latest beta build it self-updated less than a week ago or so. i just pressed ‘beta’ update this morning, but do not have 3.6 code in the drone anymore to test.
what was greyed out before - ‘Throttle Accel’ section, ‘Velocity’ section and something else i think. i had all parameters reset to default in MP, then imported pids from 3.5.5 version i assumed should have worked.

i flashed back 3.6 - all tests with 3.5.5 worked bad too, something must be off with the build.

here is MP screen. it shows greyed out windows. is it supposed to be so?

here is also a link to a picture of the build - it is quite compact, i wanted to do something like that for quite a while - it is aramttan chameloen ti 7 inch with pixracer, runcamsplit, r-xsr and TBS pro. lidar is on the belly under TBS. all fits well, but, i seems to be having issues. GPSes are on front arms. i tried it so far with and without compass from gps unit, does not seem to make much difference…
pixracer is on semisolid rubber mounts, sits well. motors are also on rubber inlays, all was supposed to be good. yet i missed something, it seems.

i retested it on backyard with way heavier 5000mah battery.

results still bad, but better - there is no flip. on min throttle in both pos hold and alt hold it is able to get off the ground and shakely hover at .3-.7m altitude. then all gets weird.
in alt hold it react to all inputs - pitch/roll/yaw. if added a little bit more power on throttle it darts into the sky straight up. dropping throttle down is ignored, only motor kill switch helps to drop it.

position hold is weirder. first, it was complaining a lot on gps speed value to be 1.7 - 1.5 when it expects 1.0, considering both gps sensors had 9 and 11 sats in 3d lock mode. then, upon arming it would also hover up, BUT - it would immediately start to drift, and was completely ignoring inputs from roll/pitch that would require to kill motors asap. and, ekf complaints like crazy on compasses, considering quite a tight build with 230x300mm X shape may be the sad part of it…
i tried it both with 3 compasses using on the external gps, and with 2 compasses on the pixracer - does not seem to do much good. logs are below - if anybody may have a look and decipher anything from them it would be great.

i would love to blame compasses on all this but it is not obvious why it darts up into the sky like that instead of hovering gradually. build has crazy power potential, i may try to put it on the smaller props to make motors run at 50-70% power for test instead of what was now, but, it is odd.

what is also odd - i just noticed looking at logs - i saw current values reported in the taranis telemetry on the screen. power module ia ascp4 on pixracer, setup in a usual way. malink logs somhow do not have CURR section in them, and motor to compass calibration also refuses to run saying there is no CURR. what is that about?

still, it is 3.6 behavior with dart into sky. on 3.5.5 it was shaky like hell, but did not dart up like this. also, i think in loiter it did react to inputs on 3.5,5 version.

log 13 is with 3 compasses, and pos hold with alt hold mix.
log 14 is 2 compasses and only alt hold, i think.

Paul, you’re missing the whole beta-testing ideea. 3.5.x is a mature release and unless you’re sporting a flight controller that wasn’t supported, you’re supposed to first tune your copter to rock-solid on it before attempting newest beta. Only then, with a well-proven machine, that sits still, fights winds in centimeters, spins around its GPS mast in loiter with maximum yaw, and runs autopilot missions like a champ, to name a few, you can have a basis of comparison for the latest release candidate.

it is back on 3.5.5 and i have 3.5.5 logs as well to look up, if you wish to help. issue is pretty much the same.
regarding this screen:

is supposed to be like that or not? are those greyed out pids deprecated now?

PS. after some tinkering with PIDs it is flying now - very wobbly, in alt hold. a lot of work to do.
PPS. 5v bus on pixracer was overloaded. need to do more tinkering and filtering. crazy stuff, those interferences.