An AutoTune Puzzle

I’ve been poking around this site (in all the wrong places I bet) looking for a “sticky” on how to post a log file (.bin). Any suggestions? Tried using the upload button (4x) but it simply stops along the way.

Is the upload button how files should be uploaded for analysis help? Or should I use another tool like Google Drive?

Also, my problem revolves around 3.6 and an AutoTune attempt. Is this the right forum?

Love this forum and any help is appreciated.



I not absolutely sure but I believe that the best way is to upload it to your dropbox and share the link in the topic you create.


This picture sums up a recent AutoTune. There are three take-offs and three landings. The last landing wasn’t pretty as throttle was up and copter was coming down.

First section of the graphic is AutoTune in Roll axis. No issue. Second (middle) section is a Pitch axis AutoTune. Again, no issue. Landed and switched to Yaw then took off and you can see Motor 3 is “weird”. It’s dipping down on Yaw movements. ESC issue? This was all done in one “take” with no power cycles.

Here’s a try at posting a link to the .bin file that’s in my Google Drive. It’s a 12Mb file so my apologies.

The other “peculiarity” is the final “landing”. I’ll see if I can post a zoomed in picture of the throttle input and the altitude.

To summarize I’m trying to figure out:

  1. What’s up with motor 3 output during the yaw section of the AutoTune?
  2. Why the hard landing?

Of course when I came back the next morning and started the Yaw AutoTune straight off it worked flawlessly. Rather than blabber on I’ll let you ask about configuration and components.

Really appreciate your thoughts.


I’d try a regular flight or hover for 15 min, and see if it’s related to things heating up. If things act up after a regular flight, you’ll know it’s not related to the beta firmware, or auto-tune.

Sorry wicked1. Just realized you had replied. I’m still fighting this issue. I made a more recent post called Droopy Arm… I’ve concluded it’s not heat related. Took heat shrink off ESCs, mounted them on top of the arms so there’s plenty of cooling. The Droopy Arm post shows the issue right from the git go. ESCs are barely warm.

Prior to that post I swapped out the ESC and Motor (individually) and problem persists on the same arm. I’m perplexed.

Unless someone chimes in with something I haven’t thought of I’m going to ditch the Bl_heli32 ESCs and go back to the old Turnigy’s and see if the issue goes away. Doesn’t make sense with issue only on one arm and multiple ESC/Motor combinations but perhaps there’s something in ArduPilot related to the new ESCs I don’t understand.

I offer you a very belated thanks for the reply.


What do you have the MOT_PWM_TYPE set to? Have you checked in BLHeli 32 suite that all ESC’s are configured the same?

Nevermind, I see it in your parameter file set to 0. With those ESC’s I would at least use Oneshot 125 but that isn’t likely to fix the problem. Describe the hardware on this quad.

600MM TBS Discovery Style Frame
T-Motor Navigator motors - MS3508-20/KV-580
12" Props
Pixhawk FC (don’t recall version)
Wraith32 V2 ESCs

Was going to use Oneshot 125 protocol but wanted to make as few changes as possible and then progress the protocol. If I get time this weekend I’ll try changing it.

Yes, all ESCs are configured the same. I am using the ESC params to reverse two of the motors (as opposed to swapping motor wiring). But essentially they are all the same.

Appreciate your time and thoughts.