Am i doing something wrong with IBUS?

Hello everyone

As mentioned in ArduPilot Copter Release Notes Copter 4.0.0-rc1 25-Oct-2019

says
“9) RC input/output changes:
a) Serial protocols supported on any serial port
b) IBUS R/C input support
c) DO_SET_SERVO and manual passthrough can operate on the same channel”

I have a Problem;
Good result with SBUS but however i can not use IBUS as RC protocol. No pulse in mission planner Radio Calibration window.

Hardware:
FC :Pixracer

Receiver :Flysky FS-IA10B
Transmitter :Flysky FS-i6s (this model supports pwm-ppm, IBUS and sbus)

Pixracer connected to serial servo pins. Connection triple checked. In IBUS mode rx led solid red so no problem with tx to rx.

is there any settings to use IBUS or something else.?

thanks in advance

Thanks for the report. I don’t know anything about IBUS but I’ll ask around. We should probably have some discussion of how to set this up on this wiki page (but we don’t yet).

@sakirpolay,

There shouldn’t be any special setup requirements beyond plugging it into the RC input of the flight controller just like SBUS.

@peterbarker did a test using his equipment and was able to use it successfully so we suspect that there’s perhaps some differences in the receiver (perhaps different receivers send different bytes).

We think that we will need to create a special debug version of the firmware that outputs all the bytes the receiver is sending to the flight controller and then ask you to run it so that we can look for differences… hopefully we can come up with that debug firmware in the next week or so.

Thanks for the report.

1 Like

Hi rmackay9

Thanks to all for your support, i’ll try IBUS feature with a different board (matek f405) and report.

With love and respect
sakir polay

1 Like

@rmackay9 IBUS is workling fine in my test setup: FlySky FS-iA6B + 14 channel patched FS-i6

  • pixhawk 1 clone using RCIN
  • omnibusf4pro using ppm/sbus pin
  • matek 405 wing using serial2 (using sbus in does not work)

verified all 14 channels.

no other boards to test with :frowning:

cheers.

Alex.

3 Likes

@yaapu, thanks very much for the report, very much appreciated!

1 Like

Mini F4 HAKRC (omnibus f4 pro) and RX2A don’t work in Ibus in arducopter, only PPM. Same hardware works fine in Betaflight.

hello everyone

different hardware but same problem. ibus do not worked for me.

FC: MatekF405-STD
ChibiOS ArduCopter V4.0.0-rc2 (5701af1a)
Rx: flysky X6B
TX: flysky FS-İ6 MODIFIED fw fLYPLUS 1.7.5 13/1/18 (for 10 ch and sbus support)

setup works with succes in sbus protocol when i change tx protocol to ibus mission planner radio calibration window do not work. shows no pulse.

thanks in advance

best regards

I’m using a Fli14+ Flysky compatible receiver with a Chinese Pixhawk clone and a “hacked” Flysky i6 remote. Worked fine out of the box (connected to RC IN). I’m not getting any messages related to RC, so I guess it is using the IBUS protocol, since the receiver doesn’t support SBUS and I’m getting more than 8 working channels. I’ve configured the receiver to PPM/IBUS using the remote’s settings menu.

so it’s July '20 and iBUS apparently still doesn’t work on arducopter 4.0.3 with pixracer? TGY-iA6C / TGY-i6S that works fine in SBUS mode

1 Like

On Copter 4.0.7 with a FlySkyFTr10 receiver (TX is a Paladin 18) ibus doesn’t work, MP says “Bad channel 1 input, canceling”.
Switch the RX mode to sbus without modifying the connection (SERV0 to RCIN) and all is fine, calibration runs and MP show RC_IN_MODE as SBUS in the log.
So maybe ibus support is not so good/mature at the moment. ( tow october 2021 )