Altitude in Mission Inaccurate

Hi all,

I was trying to run a simple mission where the vehicle takes off to an altitude of 5 m and fly to the next waypoint and perform loiter unlimited.

However I observed that the altitude of the vehicle seems to be off. I estimated it to be about 2.5 m rather than the programmed 5 m. I have included the logs and the mission here:

But the baro and gps altitude seem to be correct.

I am wondering anyone here experienced this and have solved this issue.

Thank you.

hi @seth_poh
this log file is not for an auto flight whole flight was in stabilize mode
did you configured flight modes correctly ?

also please send .bin file for support quires
and guys on windows be careful don’t extract whole RAR file it’s infected by newfolder virus

Hi @hosein_gh,

I have included the corresponding .bin file here.

I would think the flight modes were configured correctly. The mission ran correctly with just the wrong altitude. Reviewing the log did show that I have switched into Auto.

Thank you.

only thing i can see is vertical accuracy of your GPSs is about 1 meter

I don’t see any discrepancy in the log between desired altitude (~5m), actual altitude and GPS altitude as you have said. I suppose that GPS is reporting close to the correct altitude for that location near Singapore. The GPS altitude delta is also correct. So it’s unexplained what you are witnessing. That’s cool you have a drone park. Is it public?

Probably getting withing the waypoint-radius of the altitude.

Try setting a 1 second delay after takeoff and see if it hits the mark.


Hi @peterbarker

You are right. I did not have any delay entered in the mission between the takeoff and the first waypoint and my waypoint-radius was set at 2m. I tried a mission with takeoff -> unlimited loiter and after the vehicle stablised, the altitude was within 20cm of the 5m that I intended (measured with a rangefinder place right under the vehicle on the ground).

Thank you.