Altitude Hold using Laser Range Finder-How to ignore tables and platforms of certain height

Hello Everyone

I’m flying my drone with the pixhawk in Altitude Hold mode, using laser range finders pointed down. Barometer is turned off.

When it flies over a table of sorts, a bush or a platforms, the drone climbs to maintain the same altitude as before. Is there a way to disable the “readjustment” of height if the height change is above a certain threshold?

Thanks a lot!


Maybe you can try with RNGFND_GAIN parameter.

Used to adjust the speed with which the target altitude is changed when objects are sensed below the copter.

Maybe you can soften it a bit so that altitude change is slower, can’t remember if the default is at slowest already but worth a check.