Altitude control in Loiter and Althold

Hi All,

I want to know which parameters should I investigate to good understand altitude oscillation in forward flight. For example, when I’m start flying straight ahead, my copter goes slightly down. It doesn’t change in different modes like Loiter and Althold (but maybe there are different parameters for these two modes)

I know about PSC_POSZ_P and ATC_THR_MIX_MAX, which parameter should I change firstly and investigate for this strange behavior. Maybe You have some experience with it and you can help me.


That typically is a barometer issue. Protect it from wind and prop wasch and it should improve.

Search this forum for more details on thi issue

Is there any option to change barometer source ?

Also, today when I was flying there was no wind ( less than 2m/s). I was flying really slowly ( less than 5m/s) Are you sure that is barometer issue ?

The problem is the air pressure difference caused by horizontal movement and wind.
When there is no wind and no horizontal movement you do not have the problem, right?

this parameter seems relevant. not sure how effective it is though. worth a try.

I see, but barometer in pixhawk is fully covered (it is in the box, I am pretty sure there is no wind and no rapid pressure changes)
Second barometer is in GPS. GPS is located in the back of my aircraft, slightly above the propeller spinning plane.

Give this a try to trust GPS altitude more than barometer Complete Parameter List — Copter documentation

The “cheap” pixhawk 2.4.x clones usually have no foam over the baro, or very little.
It’s easy to pull apart the case and put a good piece of foam over the baro. There’s even a part of the case that’s designed to protect the baro and hold the foam in place.

A cover or dome over the whole flight controller area is good too. Prop wash and wind across the flight controller causes a low pressure inside the case - even with foam over the baro, and even with more expensive flight controllers. The copter thinks it’s rising unnecessarily so it reduces motor output to reduce altitude.

1 Like

Dear xfacta,

we have original Pixhawk from your distribution… Then I think it is not a cheap clone, but maybe you produce some shitty software. Anyway flight controller is placed inside a closed box, no wind, no extra pressure changes, no temperature changes. Even we have no vibration because we use super dumper system because yours imu dampering sucks a lot.

Then maybe there are some software parameters which I can check to be sure that all working fine? Or maybe I should check some pid’s parameters to exclude altitude oscillation in my case?

Could you be helpful for one time?

I dont really understand what you mean - others and myself try to be helpful but you havent described your copter, the components or provided a .bin log so all we can do is guess and provide general advice.
I think I even looked through some of your other posts earlier to work out you had a Pixhawk1 2.4.8 - which is definitely not known for it’s high quality and workmanship (some of those 2.4.8’s are good, and some are not)

What makes you think it’s my IMU damping or my shitty software?
Since you know what’s wrong why dont you fix it and provide the fixes back for the rest of us?

1 Like

If your damper is too soft it will actually amplify vibrations instead of reducing them.

The ArduPilot project is a software only project.
We do not develop nor sell hardware. We also do not sell software.

When we ask you for logs so that we can help you, please provide them.

You’re welcome, here is my log file. 2023-05-18 13-34-48.bin - Google Drive

That is our next project when we had quite high vibration issue. (because it is around 70 Hz we decide to use external dumper system which allows us to eliminate vibration, mostly. Why 70 Hz is so difficult to reduce? Because pixhawk orange and orange cube plus has the same resonance value, and it is around 70 Hz) And now It looks like good enought.

BTW, all my posts here were about pixhawk orange and orange plus:)

In log file you can find EKF line switching, I really don’t know why it was happened. I don’t see a visible magnetometer or compass issue. I use only internal barometer (which is closed in special space, as I have written, no wind etc) and external magnetometer (It is located slightly above propeller spinning plane and around 1.3m away from motors.

So I have issue with altitude control after forward move, my copter goes slightly down. I suppose that is related with ATC_THR_MIX_MAX parameter, but in my smaller copter this parameter doesn’t change a lot. Also, I suppose it can be related with PSC_POSZ_P parameter, but it also didn’t change a lot in my smaller copter. If it is a barometer issue, tell my why. As I know well, all EKF lines use the same internal barometer, and it shouldn’t influence on EKF

The reason for barometer noise?
Venturi effect caused by airflow.

Try this - do a back-to-back run - very simple.

  1. Take off, hover, pitch forward, accelerate, 100m or until you see the altitude drop, and then brake to hover. Then return to take off and land.
  2. Place a piece of tape over the USB and SD card port on the cube/carrier board.
  3. Repeat 1.

Inspect the results and see if you can see a difference. I have seen this tip re. tape over the SD card/USB port posted elsewhere. Come back with those results and observations.