AltHold Pilots input very sluggish

Hi there,

I’m running an 5" quad with Pixracer for quite a while now. After a hard- and software update the AltHold (and also Loiter) reacts different to pilots command than before. So I was searching for parameters for quite a while now.
Coming from 4.0.3 to 4.1.3
EK2 to EK3
Pixracer R14 to R15
but didn’t make much effort here. When going up, after centering the throttle the copter still climbs several meters (it’s not only the kinetic energy) and when decending it’s the same issue but even more unwanted.

It’s 6m after a moderate decent.
So here’s the log if someone would be interested:

Before the update the copter reaktion in AltHold was a lot more pleasing (aggressive :wink:) to me.
The AltHold itself is working ok, if you press/lift the copter by hand. Can be seen in the log at 14:20:03 to :07

Increase the PILOT_x_x parameters. Unrelated but I notice that you have INS_ACCEL_FILTER at 101Hz. The performance of this craft looks good and I suppose FFT is taking care of noise but I don’t think there is any benefit to having this that high. In fact on my 5" with a PixRacer that I tuned up for very fast auto flight, and in general one of my best performing craft, I lowered this from default. But again performance looks good!

1 Like

PILOT_* parameters are at the max:

If I increase them it seems to get worse, maybe software switches to default?
With 4.0.3 I had _ACCEL_Z at 3000. I liked that :laughing:

1 Like

Ignore the “max”. In most cases it’s an artificial max for the parameter.

did you ever try _ACCEL_Z > 500 ?

is it > 100km/h ?
That’s my barrier in auto
Acro goes faster :grinning_face_with_smiling_eyes:

Easily. I have a 4” going >140kph in an auto mission and a 5” a bit less for lack of power.

cool, I think I’d have to increase angles…

I increased it to 80deg. A lot of good info here:

Hoping for warmer weather :sunglasses:

Dave, thanks for the hint, another playground :upside_down_face:

But coming back to the altitude controller. I found parameters to increase the vertical speed but the connection to the throttle stick is still a little loose in my opinion and I’d like it more crispy :wink:
As one can see at 14:52:36 the copter is still loosing 4m after the decent is supposed to stop. The motors are not maxed out so what is the limit here?
… ?

the log can be found here:

Any hint would be appreciated, thx

1 Like