Align E1 900 Helicopter tuning

I am tuning the Align E1 900 helicopter according to the Trad Heli Tuning.
I try to change ATC_RAT_RLL/PIT_VFF. But the curve of Rate.R/P and Rate.DesR/DesP just keep shaking rapidly like this.

The mechanical and swashplate set is normally.
Appreciate for any suggestion

It’s most likely that either the Rate P gain or Rate D gain or both are too high. You need to cut these gains in half for the affect axes and see if the oscillations go away. If not then keep cutting them in half until they do go away

Consider posting in the traditional helicopter section of discuss. More heli users will see your post. Are you using versiion 3.6?

1 Like

Hi Bill,
Thanks for your suggestions.
Yes, I use the Copter 3.6.1-heli firmware.(The heli load with 3 kg gimble.
So should I keep the VFF, and cut the ATC_RAT_RLL/PIT_P and D in half? Will the heli out of control when cut gains in half?

If you are seeing oscillations that are less than 10 hz then yes it is most likely your rate P and D gains are too high.

I would suggest upgrading to 4.0.8 or 4.1.1 (when it comes out as a stable version). Don’t upgrade to 4.1.0. It has a known bug for heli’s. 4.1.1 fixes the bug.

1 Like

Hi Bill,
Today I try to cut rate P params ATC_RAT_RLL/PIT/YAW_P in half, but the curve Rate.R & Rate.RDes still have the same oscillation about 10Hz like this.

In ATT data, the Des R/Y & R/Y always has 5 degree deviation like this.

In stabilize mode, I feel the heli control response become slow and the yaw axes seems loose. So I give up to keep decrease the rate P. Should I keep decreasing the rate gains? Or maybe use 4.0.8 firmware will change the situation?

Here’s full param list and bin file, thank you and looking forward to any suggestions from you!
align-E1-2021.11.03.param (13.5 KB)

bin file

If you are following the tuning guide then you missed one of the parameter settings. Both the pitch and roll I gains should be set to 0 initially. You have them set to 0.61. That is way too high and probably why the aircraft feels sluggish. It looks like you have high enough FF gains to be able to zero the Pitch and Roll Rate P and Rate D gains without losing control of the vehicle. The oscillations should disappear. If they don’t then it is unlikely it is a feedback instability and maybe a vibration issue. Also you will want to ensure you have Fast Attitude checked as well in the log bitmask. That will log rate data at 400 hz and enable us to see if there is a rotor vibration issue

1 Like

Hi Bill,
I think you are right. I set pitch and roll I gains to 0, try to decrease the rate P and rate D gains. The vehicle didn’t lose control but the oscillation still exist. I checked Fast Attitude and in the log I found that the rate curve frequency is about 24Hz while the rpm of rotor is 1400. So I think it seems like a rotor vibration issue.


So how can I avoid these problems? Does it help to replace the cushions or check the balance of the blades?

If the frequency of the oscillations shown in the graph are at 24hz (1440 RPM) then it is definitely a 1/rev vibration which is indicative of rotor imbalance. It is possible that your mounting location or method can be exacerbating this. First thing I would do is check your rotor balance. Pull the head, shaft and all, from the heli and balance it on the bench. I realize that this may not be so easy with 900 mm blades but that is the best way to ensure your static balance looks good. Once you are satisfied with that and if you still have an issue then check the mounting of the AP.

Hi Bill, shouldn’t he use the notch filter too?



@heri yes @zhenghan can use the notch filter. I believe there was a static notch filter in 3.6. If he upgrades to 4.0.8 then he can use the harmonic notch. But I still think he should make sure he has done everything he can mechanically to reduce the 1/rev vibrations. Then the notch filter can be used to clean up the rest.


Hi Bill,
Last week, we try to improve the machanical condition and use softer dumpers. And I also see @heri 's suggestion, use the notch filter in 3.6. But the vibrations still exist. I think it is impossible to completely eliminate the vibration on our vehicle.

I have no idea that is the vibration result in the rate.R/rate.P away from Des.R/P? We set VFF to 0.2 and I think its big enough, but it seems still below des.
What we also care is about the atittude in loiter mode when vehicle hover from a sharp move. There is a “double stop” like this. What result in this?

Hope for any suggestion~

Please post a log from this flight with the notch filter on.

Hi Bill,
This is the bin and the param file.
align-11.11.param (13.6 KB)

The notch has improved it a little. I would suggest increasing the attenuation (INS_NOTCH_ATT) to 40. That will probably be the best you can do.

I want you to fix this parameter (H_COL_MID) right away because as you upgrade your firmware to newer versions, it will be imperative that this parameter is set properly to keep the aircraft from shutting engine down in auto modes
Please make sure that this is set to the PWM that corresponds to zero collective blade pitch. If you are using asymmetrical blades then set it to the blade pitch that corresponds to zero thrust on the rotor sytem (typically -1 or -2 deg)

Please turn on PID logging in the log bitmask.

Looking at your desired and actual attitudes, the roll being off is expected as we have low I gain and the aircraft has to hover with a right bank angle to offset tail rotor thrust. However there is a large difference between the desired and actual pitch. So I expect that your longitudinal center of gravity is off. You will want to adjust your battery location to make sure the center of gravity is below the main rotor shaft. We can make changes to your gains to fix the issue with the desired and actual not matching but it is better to make the mechanical adjustment.

As for you tuning, for now the VFF gains for pitch and roll look pretty good. I’m just looking at the peaks and they seem to be the same magnitude between desired and adequate. It helps if you make sharp stick inputs to achieve 20 - 30 deg attitude. Even though the traces are offset, as long as the magnitude of the peaks match, then the VFF gain is pretty good.

Here is what I would recommend. Follow the tuning guide to set rate P and Rate D gains for the pitch and roll axes. Once you have them set then raise your I gains to 0.1 and the ILMI params to 0.08 for the pitch and roll axes. Changing the I gains and the ILMI parameter will make the traces lay on top of each other.

When you have completed the P and D gain tuning and raise the I gain and ILMI, send me a log of a flight.

@bnsgeyer Hi Bill, one question, just for my understanding.

Do you always have to proceed in the following order when tuning:

  1. set the values for pitch and roll according to the tuning pages in advance. Set I and ILMI values to zero
  2. then try to find the values according to the tuning instructions.
  3. and only then(!) set the I and ILMI values according to your instructions to 0.1 and 0.08

So, would it be an error to do step 3 before 2 ?



Hi Bill,
here is the flight bin & param file.

first flight.bin
second flight.bin
align-11.16.param (13.6 KB)

In the second bin file,we tried loiter mode and turn on PID logging in the log bitmask, with I and ILMI change.
But when the heli take off, it severely tilted to the right, and shake in the loiter mode.
We adjust the P and D gain according to the tuning guide, should we start to fix Vol XY PID?

Thank you for any suggestion.

Hi Bill,
Today we try to tune the I, IMAX, ILMI to fix the problem. we increase I to 0.12 and set IMAX to 0.15 according to PIDP & PIDR. We think the ILMI is too high, which will result in severely tilted to the right when take off. Here is the bin & param file.

align-11.18.param (13.6 KB)

What confuse us is the “double stop” in loiter mode is still there. It seems that the tuning didn’t solve this problem. We decide to change LOIT_BRK param.

I have a few suggestions for your latest tune. First I think your ATC_RAT_PIT_VFF gain is low. I would suggest raising it to 0.19. Your ILMI in both pitch and roll is too small. Here is a plot of the integrator term in the PID

You can see that they are both sitting on the ILMI limit. I think you should raise the ILMI. Increasing this value will help keep the actual attitude tracking the desired attitude especially this bias that you see below

I looked at the second flight from your previous post and the attitudes tracked well. Did you only have problems taking off in loiter with the vehicle excessive leaning over? Did it behave the same way taking off in stabilize. You may try increasing ILMI from 0.02 to a value where you still get good takeoff without excessive leaning. The better choice is to upgrade to 4.0.8 or 4.1.1. There is a new integrator management scheme that significantly improves this behavior.

I don’t know much about changing that braking behavior. In addition to LOIT_BRK, you may try lowering LOIT_BRK_JERK. Making it lower will slow how quickly the braking is applied and could stop the double braking.

Hi Bill,
Thanks for your suggestions.
We raise the ATC_RAT_PIT_VFF, increase the ILMI to 0.08 and set HOV_TRIM from 300 to 0 to prevent excessive leaning. The Des P/R seems better than before.

As for double braking in loiter mode, we decrease BRK_JERK and set BRK_DELAY from 1 to 0. The vehicle seems well in loiter mode after sharp move in roll and pitch.

Can we improve the performance by set proper rate PID? In the ATT curve there is still overshoot in both pitch and roll. Is the vehicle safe enough to test auto mode performance?

Here is the bin & param file.

align-11.20-2.param (13.6 KB)

Hope for your suggestion.