Airspeed sensor issue with ground speed value


The issue: in mission planner when I enable the airspeed sensor the ground speed value becomes identical to the airspeed value.

This is my first time using an airspeed sensor. As of now I am testing everything on the desk I did not go to the field yet.

My flight controller is pixhawk 2.4.8

My airspeed sensor is: PX4 Differential Airspeed Pitot Tube MS4525DO + Pitot Tube Airspeedometer Airspeed Sensor for Pixhawk PX4 Flight Controller

The airspeed reads correctly with default settings. When I blow in the tube it’s giving me correct values.

When I enable the use of airspeed sensor in mission planner the ground speed value become identical to airspeed. When I blow in the tube the ground speed also increases.

I would appreciate any help since I am new to airspeed sensors.


The ground speed doesn’t come straight from the GNSS receiver, but from the AHRS filters. These try to reconcile the airspeed readings and the GNSS readings.

Can you tell us a bit more about your setup?
Are you using GNSS receivers?
Was the vehicle armed when blowing into the tube?

1 Like


Thank for the replay

I am not using any GNSS receivers.

My setup is basic. Pixhawk with the provided M8N with compass model. I am using a usb cable connected to my pc desktop to use mission planner.

The ground speed issue remains wither the vehicle is armed or disarmed.

There is an error massage when I connect to mission planner “ GPS 1 detected as u-box at 230400 baud “

Please note the the GPS compass is not plugged since I read that it is not mandatory. Plugging the compass using an i2c split board makes no difference regarding this groundspeed issue.

Appreciate your help

GNSS stands for “Global Navigation Satellite System”, that includes GPS.

1 Like

Actually I can’t reproduce your issue in SITL:

I set SIM_WIND_DIR=0 (North wind), SIM_WIND_T=1 (constant wind regardless of altitude) and SIM_WIND_SPD=10.

You can see in the attached picture how the airspeed is measuring the full wind, but the groundspeed is still at 0.

I don’t know why your system is behaving like that.
Would you perhaps like to share your parameter file?

1 Like

Yes I would
I will post it later when I get back home.
Thank you for you fast response

First time in upload a file here.
Let me know if it works

ground_speed_issue 2.param (16.7 KB)

It’s not apparent to me if this is a problem or why it happens.

A few suggestions:

  • Update to the current stable ArduPlane version.
  • Enable all of the arming checks.
  • I don’t think ARSPD_PIN=15 (analog) is the correct setting for your sensor.

I will do that.

Also I noticed that the GPS is not getting a good fix.

The problem could be the GPS and not the airspeed sensor.

I’ll double check everything and get back to you.

Thank you for the follow up

Greetings George

I downloaded the current stable ArduPlane version 4.3.7. It did help with the issue.

I Enable all of the arming checks. these are the massages I got:

5/18/2024 4:42:27 PM : PreArm: GPS 1: Bad fix
5/18/2024 4:42:27 PM : PreArm: AHRS: EKF3 Yaw inconsistent by 178 deg
5/18/2024 4:42:26 PM : Airspeed 1 calibrated
5/18/2024 4:42:25 PM : Airspeed 1 calibration started
5/18/2024 4:42:25 PM : Barometer calibration complete
5/18/2024 4:42:25 PM : Updating barometer calibration

regarding the airspeed pin, I tried changing it to all of the ones in the list but has no affect in the issue. the groundspeed still moves with the airspeed as if they were the same value.

I did not manage to get a good GPS fix since I am using my desktop computer inside the house in a basement.
do you think Bad GPS fix is the reason for this issue? should I get a laptop and try it outside?

soon I will try I different airspeed sensor just to make sure that we are not dealing with a faulty airspeed sensor.

your help is much appreciated

I’m a bit confused. Did upgrading help or not with the issue?
By the way, the current ArduPlane is stable is 4.5.

I don’t think changing the airspeed sensor will make any difference.

It is possible. If I get the time I will try to reproduce it in SITL as well.

Sorry I meant it did not work.

I downloaded the latest zip file for the update.
From mission planner when I try to update the software I am getting an error.

I am not sure what to do, I tried everything.


Today I used a laptop to go outside where I usually get a gps fix. The GPS has solid blue light. But in mission planner it says no GPS fix.

The GPS wiring is ok, when I disconnect the GPS it says no GPS, when I connect it back it says GPS no fix.

On the map in mission planner the plane location is wrong, it’s in the middle of the Atlantic Ocean.

I am assuming the groundspeed error with the airspeed sensor is related to no gps fix.

Please help

I seem to recall that once upon a time a manufacturer reversed two wires on a sensor and sent it out into the world. This seems to fit your problem to a T.

Don’t switch the power or ground wires of your gps module as it is getting power so it’s not those wires for sure.

I bet the clock and data wires are reversed on your gps module or your airspeed sensor, start with the airspeed sensor then gps module. Disconnect and uncheck the use of airspeed sensor and take your outside and see if your gps module works. Don’t go by the lights on the modules rather confirm via mission planner that you did or didn’t get a gos fix.

I was not aware that you could run 4.5 on a 2.4.8 Pixhawk as that pixhawk did not come with enough memory to hold that big of a firmware size but it’s possible someone upgraded the 2.4.8 as it is open source.

Regardless, upgrade your autopilot if and when you can as the 2.4.8, while cheap and an ok starting point, is no longer supported by the software gods and that very well could be your issue. If you want to test this idea look for the last firmware version posted for the 2,4,8 Pixhawk, it’s gonna be in the 2 or 3.0 versions but I’m not certain.


The airspeed sensor is working now.
I think my mistake was that I was dealing with a new flight controller that never got a GPS fix not once.

I reinstalled the firmware, the airspeed sensor was connected from the beginning. I did get a reading from the start and the ground speed was 0.

I went outside to get a gps fix. And now the airspeed sensor value is not as the groundspeed value which mean the problem is solved.

I also disconnect the external compass this time and decided not to used as I read it is optional and not mandatory.

Thank you all for the help