After Upgrading to 4.3 stable, I get: "Prearm: Mount not healthy"

I upgraded my firmware on my board, and now I get a new prearm message that:

“Pre-arm: Mount not healthy”

This doesn’t seem right. The last time I tried arming it, I didn’t get any warning about a mount not being healthy, and haven’t flown it.

Need more info, like the flight controller, the Mount details and so on.
Ideally set LOG_DISARMED,1 and reproduce the error then set LOG_DISARMED,0
Let’s see that .bin log.

If you’ve got a Pixhawk1-1M or similar there are some features disabled in the newer firmware versions, you can use the custom firmware builder to add in required features - if that is the issue.

I’m using an orange cube on an octocopter. I’m not sure what you mean by “mount details” though… Here’s my log file:
.bin:
https://drive.google.com/file/d/1NV4gB4nTo2jkXiQGIqLXPRQIJoUA4unt/view?usp=sharing
.log:
https://drive.google.com/file/d/15eCm0B7LtwwZe2VVJRHEaErK1NysxMir/view?usp=sharing

Problem still exists (thought I had it solved briefly) I tried loading the old firmware version, and did not get the prearm warning.

An example of a mount is a gimbal, do you have any such gear mounted?

No; I don’t think so. I do have landing gear connected. I tested it, and it’s working fine. At one time I was also trying to get my gimbal working on it (without siccess,) so it’s possible I’ve adjusted something in the past with a gimbal. Do you have suggestions of paramaters I should check?

Here’s a look at my “Camera Gimbal” settings. Notice that for “type” there are no options

I haven’t looked at the mount parameters.

We’ll probably have to wait until Xfacta answers, he might have used the mount feature before

params2022november23.param (18.2 KB)

I uploaded my params, in case it’s useful.

Change MNT1_TYPE,6 (Gremsy) to MNT1_TYPE,0 (none) or something else like 1 (servo) if you are going to set it up.

You should be able to stay with the latest stable firmware

2 Likes