Advance mission planning Issue

In ArduPlane SITL whenever I try advance mission planning, After land and disarmed the vehicle got stuck in Pre Arm: in landing sequence, and it not being armed again.
And it occurred only in Arduplane 4.2.2 .

Please help me out.

This might help.

Thanks @myozone for your guidance.
But this video is for Copter only. In plane params are little different than copter.

I had a similar situation.
I haven’t solved it myself, but if I press the Arm button in the Mission Planner when this message is displayed, the aircraft will take off and the mission will continue, so I am using it for now.
Does this happen in version 4.1 and below?

Such problems, I have not encountered in 4.1
This only happened in 4.2.

People who interested in this, the ARMDISARM function is now 153 :slight_smile:

I’m getting this now on a real plane running ArduPilot 4.3.2. It is now stuck at “PreArm: In landing sequence.”. I have tried resetting the mission to waypoint 1 and it doesn’t help.

This seems to have happened when I did an RTL with an auto land. For some reason even though the plane landed, it was still “Flying” when it was on the ground. I think this might be because I landed on a slight slope and the landing location was a meter or so higher than the takeoff location. This is the log of that flight.

You can see the first “PreArm: In landing sequence” message at the end of the log - after the plane has landed and disarmed.

You can try setting a switch to RCn_OPTION,24 Auto Mission Reset. Or you can Reset the mission rather than just setting WP1 as the next WP.

I use QGroundControl at the field. Do you know how I can reset the mission using QGC?

Not sure to be honest. I just use the switch to reset the mission because I don’t always have a GCS with me when I’m flying.

So are you saying this is a normal thing? The mission finishes “incomplete” even though the plane has landed. Doesn’t that sound like a problem?

Can you clarify the issue? Is it that you couldn’t restart the mission, or the plane didn’t disarm after an RTL?

I can’t arm - there is now a PreArm - so I can’t even fly at all (mission or not) unless I Force Arm.

@tridge This appears to have been added by this commit: Plane: refuse arming if we are in a landing sequence · ArduPilot/ardupilot@20f641d · GitHub
But it wasn’t caused by a failsafe. I deliberately switched to RTL mode from the transmitter and the plane successfully completed an auto land, and was disarmed, so …

There were three things that came up as pre-arm issues.

2023-01-08 14:55:54.341 PreArm: In landing sequence
2023-01-08 14:56:24.341 PreArm: Hardware safety switch
2023-01-08 14:56:24.341 PreArm: AHRS: DCM Roll/Pitch inconsistent by 10 de

I can’t answer the “Landing Sequence” issue.

Hardware safety switch … BRD_SAFETYENABLE,0.

AHRS, perhaps running magfit might help. The sloped landing site may have also been an issue. The plane was reporting a very significant nose down pitch around 14.54.28. At first I thought you may have picked up the plane or moved it, but the disarm command wasn’t reported until 14.54.49 so that’s not it.

I’m fine with the other two, yes the plane pitched over when it landed. Then I manually disarmed from the transmitter as I was walking over to pick it up.

its the In Landing Sequence that I can’t solve.

Noticed this yesterday as well in a real flight!

1 Like

I see that @tridge had the same problem on his Griffin flight here. GriffinPro MX16 Screen Recording - YouTube

I just fired up my GlaStar/Durandal a week later and it was still showing “PreArm: in landing sequence” even though it landed and was switched off for a week.

I finally figured out that on QGC if you right click on the “takeoff” waypoint and swipe the slider to reset to WayPoint 1, it will reset the PreArm. It works but it’s really a “workaround” no?

Just out of curiosity, are you using DISARM_DELAY? I am and have mine set to 5s.

No DISARM_DELAY on this model. It is interesting though, I have two models currently flying ArduPlane 4.3.3 and this happens often on one, but not on the other.
I think there needs to be a mission on the plane which is executed at least part of the time during flight (RTL triggering DO_LAND_START seems to cause it) but then I take over and land myself, likely in FBWA.
It looks like that might have been what happened in Tridge’s flight.

In my example photo, I was flying in mixed FBWA, GUIDED and then AUTO for a landing sequence. I let the mission play out completely without interruption and let it land. Still got the message. Weather has not been good to test again.