Servers by jDrones

ADS-B ---- Live traffic displays on MP intermittently

I installed the uAvionix ADS-B PingRx recently to my Quad running Arducopter V4.0.5 on Pixhawk 2.8.4. PingRx is connected to serial 4/5 port of Pixhawk. Live traffic is displayed on MP someday, but the next day, there is no live traffic (compared to online flight tracking software and local airport traffic movement), even though the PingRx LED flashes.
I also tried connecting it to Serial 1 and Serial 2 port of Pixhawk, but nothing change. I did not change any setting after seeing live traffic display on MP

Screenshot of ADS-B related setting is attached.

The SR1_ADS_B and SR2_ADS_B are both 5 Hz.
I also tried checking the box under GCS ID in PLANNER page, and agreed on the default values of Server IP as 127.0.0.1, and Server port as 30003. But all these do not help.
Thank you.

update your mission planner

Hi Michael,

I updated MP (1.3.74) but still does not display live traffic. Also tried again Telem 1 and 2 ports, Serial 4/5 port as well. The last version 1.3.72 was working alright displaying live traffic by just enabling the ADS_B.

Regards

whats your SR1_ADSB param set to?

Hi Michael,

Thank you for your reply. As stated in my first post, it is said to 5 Hz, same as SR0, SR2 and SR3.

I just tried again, still no live traffic, LED of PingRx still flashes. Very weird. It was working normally before, and I swear I did not change any setting in between.

Appreciate your help.

Hi buddy i had heap issues uAvionix ADS-B PingRx so i sold it and built one
why don’t we test mission planer first do you have internet on pc or laptop your using ?
if so lets move on
remove ping RX from usb /serial port
for ads-b setting in MP set server ip address put in 112.141.254.37 then click ok
and server port number 8078 then click ok
then go to main data screen
navigate to Melbourne Australia tell me if you can see ADS-B traffic ?

just check web server is pick up some planes
thats at ADS-B WEB-TRACKER

Hi Colin,

I tried what you suggested… disconnect PingRx from laptop USB, set IP address to 112.141.254.37

and server port to 8079, then I connect Pixhawk( i.e PingRx) to Mission Planner, and navigate to Melbourne Australia, nothing

happened. Don’t understand why I have to navigate to Melbourne.

But when I navigate back to my local area (Vancouver, Canada), I see live traffic.

I then tried changing IP and server port to other random numbers, such as 112.242.154.31 and 8235,

I still see live traffic.

I have limited knowledge on network. Can you explain why?

Thank you.

Frankie

don’t use the PingRX at all don’t even plug
and you don’t need to plug in Flight controller as well just run mission planer by its self nothing pluged in

we are going to start testing Mission planer first get that working the way it should
in MP turn off ads-b then turn it back on set the IP Address 112.141.254.37 click ok
then set the server port 8078 do see the air traffic in melbourne australia

if not type into a web Browser 112.141.254.37:8079
and if still no planes something blocking it on pc or LT it may be AntiVirus



this is what it should look like when you put in to a web browser

I follow your instruction by unplugging everything at the USB at laptop, and type in the IP and port number in MP (see attached screenshot), still no live traffic at Melbourne, but when I put it in the web browser, there is live traffic in Melbourne(also attached).

When using MP, how do you turn off the ads_b, disable it in the MP parameter list by setting it to 0,

or by unchecking the ADS-B box in MP config–planner page ? I tried both, but nothing changed.

But even there is live traffic display in MP is successful when disconnecting the PingRx from laptop,

the purpose of having PingRx in MP is to display your UAV at the same time with the surrounding traffic,

either for avoiding it or other purpose. If there is no display of your UAV, it defeats the purpose of PingRx.

By the way, where do we get the IP address and server port number ?

Thank you for your help.

Frankie

I’ve been following along with this because it’s something I’m interested in trying. @yak-54 I’ve tried the IP/port that you posted and like @wcfung1 I haven’t had any luck with Mission Planner. I also tried with QGC and no luck there. I was able to see the PiAware view without problem. (Long time since I’ve been to Melbourne, Thanks for the distraction)

it should work if not something is blocking mission planer from accessing the network
i just updated mission planer on my pc works fine and test on my laptop and tested with orange cube as well

once we get mission planer to work with my server then we will move on to the ping rx

I also tried with QGC, it works right away as soon as I connect PingRx to MP, without changing any setting,

just using default.

Been following this for a bit now.
Been wanting to get traffic on MP here in Canada. But no clue how to do that. That IP address is Melbourne so not much help for me. lol.

anyway curious how to get it working.

Do you have PingRx connected to MP, and activate it in the MP parameter list ?

If there is no live traffic, change the IP address and server to the Melbourne address, see how it goes.

Where in Canada ?
and i will point to server close to you

London Ontario area.
Thanks very much,

gee there is no feeders in your area maybe you should build

Anything in the Toronto Area.

IF not I will set one up

Hey Ricky
I’m going to build mine too , so we can get a BVLOS corridor between Quebec and London… no big traffic… Just Trudeau and Pearson !!

Happy New Year (can we say that now ?!?)

Servers by jDrones